Bug 727600 - some CLI redeem module messages need correction
some CLI redeem module messages need correction
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-08-02 10:52 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-08-02 10:52:11 EDT
Description of problem:

Problem 1)
# subscription-manager redeem
email and email_locale are required for notification
          ^^^^^^^^^^^^
          locale is not required for redeeming a subscription


Problem 2)
# subscription-manager redeem --help | grep EMAIL -A5
  --email=EMAIL         optional email address to notify when subscription
                        ^^^^^^^^
                        EMAIL OPTION IS NOT OPTIONAL

                        activation is complete.
                        ^^^^^^^^^^
                        CHANGE activation TO redemption

  --locale=LOCALE       optional language to use for email notification when
                        subscription activation is complete. 
                                     ^^^^^^^^^^
                        CHANGE activation TO redemption

                        Used with --email only. Examples: en-us, de-de
                        ^^^^^^^^^^^^^^^^^^^^^^^
                        NOT REALLY NECESSARY SINCE --email IS REQUIRED.


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.73.57441fb.el6.x86_64
Comment 1 Bryan Kearney 2011-08-02 13:09:21 EDT
fixed in master at 0fe311035dbf5bf3275d6e4a340ac44b79488c76.
Comment 3 John Sefler 2011-08-02 15:38:26 EDT
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64


Don't forget a fix for Problem 1) in comment 0 ...

# subscription-manager redeem
email and email_locale are required for notification

Suggested Message:
You must specify an email for notification when redemption is complete.
Comment 4 Bryan Kearney 2011-08-02 16:14:30 EDT
That comment is fixed in bfe3c5caf5124439c1fb403738848bc326b5e3ee in candlepin master.
Comment 5 John Sefler 2011-08-02 17:01:00 EDT
Verifying Version...
[root@jsefler-onprem-62candlepin proxy]# git branch
  0.3
* master
[root@jsefler-onprem-62candlepin proxy]# git show-ref | grep master
bfe3c5caf5124439c1fb403738848bc326b5e3ee refs/heads/master
bfe3c5caf5124439c1fb403738848bc326b5e3ee refs/remotes/origin/master
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: af2dc6b6-25eb-4f81-b050-6c33e803e394 
[root@jsefler-onprem-62server ~]# subscription-manager redeem
email is required for notification

^^^^  Problem 1 VERIFIED


[root@jsefler-onprem-62server ~]# subscription-manager redeem --help
Usage: subscription-manager redeem [OPTIONS]

Attempt to redeem a subscription for a preconfigured machine

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication
  --email=EMAIL         Email address to notify when subscription redemption
                        is complete.
  --locale=LOCALE       Optional language to use for email notification when
                        subscription redemption is complete. Examples: en-us,
                        de-de

^^^^ Problem 2 VERIFIED

moving to VERIFIED
Comment 6 errata-xmlrpc 2011-12-06 12:22:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.