Bug 727628 - rhevm bridge listed in Network configuration screen
Summary: rhevm bridge listed in Network configuration screen
Keywords:
Status: CLOSED DUPLICATE of bug 720957
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 731146
TreeView+ depends on / blocked
 
Reported: 2011-08-02 16:15 UTC by Anil Vettathu
Modified: 2011-08-17 16:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 08:28:40 UTC


Attachments (Terms of Use)

Description Anil Vettathu 2011-08-02 16:15:24 UTC
Created attachment 516364 [details]
network tui screenshot

Description of problem:

If RHEV-H has two or more interfaces tui displays wrong mac address for rhevm bridge.

Version-Release number of selected component (if applicable):

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.2 (0.9.el6)


How reproducible:

Always

Steps to Reproduce:
1. Login as admin
2. network
3. the mac address of the rhevm shows the wrong interface mac (here eth2) instead of eth0 mac. Check screenshot

[root@dhcp209-204 ~]# brctl show
bridge name	bridge id		STP enabled	interfaces
rhevm		8000.525400cd73fb	no		eth0


[root@dhcp209-204 ~]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 52:54:00:CD:73:FB  
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:44677 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3165 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5573684 (5.3 MiB)  TX bytes:317492 (310.0 KiB)

eth1      Link encap:Ethernet  HWaddr 52:54:00:98:20:8D  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth2      Link encap:Ethernet  HWaddr 52:54:00:E5:D4:F7  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7812 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7812 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1203850 (1.1 MiB)  TX bytes:1203850 (1.1 MiB)

rhevm     Link encap:Ethernet  HWaddr 52:54:00:CD:73:FB  
          inet addr:10.65.209.204  Bcast:10.65.211.255  Mask:255.255.252.0
          inet6 addr: fe80::5054:ff:fecd:73fb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20621 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1533722 (1.4 MiB)  TX bytes:316144 (308.7 KiB)


  
Expected results:

rhevm should show the correct mac address.

Additional info:

It looks like the rhevm is always displaying the mac address of the interface just before it or the last interface in the host. Here eth2

Comment 2 Alan Pevec 2011-08-03 11:18:23 UTC
Bridges, including rhevm, shouldn't be listed in network config screen, only physical interfaces.

Comment 9 Alan Pevec 2011-08-04 08:28:40 UTC

*** This bug has been marked as a duplicate of bug 720957 ***


Note You need to log in before you can comment on or make changes to this bug.