Bug 72765 - up2date should require newt package
up2date should require newt package
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 12:39 EDT by Michael Young
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 12:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2002-08-27 12:39:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020729
Netscape/7.0

Description of problem:
If you try to register a system with up2date in text mode without the newt
package installed, it fails witha traceback ending
ImportError: No module named snack
The snack module is part of the newt package, so the up2date package should
require the newt package to be installed.
 Note, I discovered this on a UML system I built from installing packages from
scratch, so I don't know if it is possible to get into this situation in an
anaconda installed system.
Comment 1 Adrian Likins 2002-08-27 14:31:28 EDT
hmm, indeed. Added to the spec file.

Should show up in 2.9.56 or so

Note You need to log in before you can comment on or make changes to this bug.