Bug 727655 - sanlock daemon needs uid/gid assignment
Summary: sanlock daemon needs uid/gid assignment
Keywords:
Status: CLOSED DUPLICATE of bug 658971
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 738294
TreeView+ depends on / blocked
 
Reported: 2011-08-02 18:41 UTC by David Teigland
Modified: 2011-09-19 15:28 UTC (History)
3 users (show)

Fixed In Version: sanlock-1.8-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 738294 (view as bug list)
Environment:
Last Closed: 2011-09-19 15:28:13 UTC


Attachments (Terms of Use)

Description David Teigland 2011-08-02 18:41:47 UTC
Description of problem:

errata tool complains about the sanlock spec file doing this:

/usr/sbin/useradd -c "sanlock" -s /sbin/nologin -r \
                  -d /var/run/sanlock sanlock 2> /dev/null || :

without specific uid/gid, so trying to get some assigned.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Lon Hohberger 2011-09-19 14:14:46 UTC
Specfile updated to:

%pre
/usr/sbin/useradd -u 179 -g 179 -c "sanlock" -s /sbin/nologin -r \
                  -d /var/run/sanlock sanlock 2> /dev/null || :

Comment 4 David Teigland 2011-09-19 15:28:13 UTC

*** This bug has been marked as a duplicate of bug 658971 ***


Note You need to log in before you can comment on or make changes to this bug.