Bug 727660 - Removing RHN-Proxy packages at deactivation time fails due to dependency issues.
Summary: Removing RHN-Proxy packages at deactivation time fails due to dependency iss...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server
Version: 541
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2011-08-02 18:59 UTC by Dimitar Yordanov
Modified: 2011-08-03 17:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 15:57:30 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2011-08-02 18:59:42 UTC
Description of problem:
Removing RHN-Proxy packages at deactivation time fail due to dependency  issues.


Version-Release number of selected component (if applicable):
RHN-Proxy 5.4.1

How reproducible:
100%

Steps to Reproduce:
1. Install/Activate RHN-Proxy against Hosted/Satellite
2. Deactivate the RHN-Proxy and Remove the Installed Packages via WebUI.
3. Execute : rhn_check -vv on the RHN-Proxy
  
Actual results:

error: Failed dependencies:
perl(Error) is needed by (installed) perl-Git-1.7.1-2.el6_0.1.noarch
perl(Error) is needed by (installed) git-1.7.1-2.el6_0.1.x86_64
httpd-mmn = 20051115 is needed by (installed) mod_wsgi-3.2-1.el6.x86_64

Expected results:
All packages that are related to the RHN-Proxy Installation are successfully removed.

Additional info:

Comment 1 Miroslav Suchý 2011-08-03 15:57:30 UTC
It is recommended - well strongly suggested, that machine which runs RHN Proxy is dedicated only for RHN Proxy. So during package removal we expect *only* @Base + RHN Proxy packages.

There should not be git, nor httpd-mmn. If you install it then you are on your own.

Comment 3 Miroslav Suchý 2011-08-03 17:18:28 UTC
So it seams that Beaker does not install just @base.
Looking into comps-rhel6.xml I see git in @development


Note You need to log in before you can comment on or make changes to this bug.