Bug 727673 - Mouse buttons not working in dialog boxes in Gtk3 when using xmodmap pointer = "3 2 1"
Summary: Mouse buttons not working in dialog boxes in Gtk3 when using xmodmap pointer ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 15
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 20:11 UTC by dann
Modified: 2012-04-22 03:47 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.10.4-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-22 03:47:07 UTC


Attachments (Terms of Use)

Description dann 2011-08-02 20:11:01 UTC
Description of problem:

I use fvwm2 and also
xmodmap -e "pointer = 3 2 1"

to make the mouse left handed.

Version-Release number of selected component (if applicable):
gtk3-3.0.11-1.fc15.i686

How reproducible:


Steps to Reproduce:
When running 
gtk3-demo 

selecting "Dialog and Message Boxes"

opens a dialog box, but the buttons in that dialog box do not react to any mouse clicks, what is strange is that item selected the main gtk3-demo window changes when clicking on the dialog box...

No other widgets seem to have this problem.

gtk3-demo is just an example, the problem happens in all Gtk3+ applications.

gtk2-demo does NOT have this problem.

This setup has worked for 10+ years, no other toolkits have the same problem.

Comment 1 Matthias Clasen 2011-12-16 02:48:37 UTC
It turns out that this is a bug in the X server.

Comment 2 Matthias Clasen 2011-12-16 14:07:31 UTC
http://patchwork.freedesktop.org/patch/8367/

Comment 3 Fedora Update System 2012-04-20 20:15:52 UTC
xorg-x11-server-1.10.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2011-17145/xorg-x11-server-1.10.4-2.fc15

Comment 4 Fedora Update System 2012-04-22 03:47:07 UTC
xorg-x11-server-1.10.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.