Bug 727694 - Working sets do not function in BRMS 5.1
Summary: Working sets do not function in BRMS 5.1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor)
Version: BRMS 5.1.1.GA
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 5.1.0.PostGA
Assignee: Tihomir Surdilovic
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 22:01 UTC by Jeff Slone
Modified: 2011-09-19 23:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 19:01:05 UTC
Type: ---


Attachments (Terms of Use)

Description Jeff Slone 2011-08-02 22:01:35 UTC
Description of problem:
Using Guvnor in BRMS 5.1, if you create a new working set, the created document is empty. Each of the tabs created for the working set is empty and you cannot add facts to the set or do anything else. The feature is completely unimplemented.

Version-Release number of selected component (if applicable):
5.1GA

How reproducible:
Always

Steps to Reproduce:
1. Choose Create new > Working set.
2. The document created is entirely blank. There are no options to do anything with the working set.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Anne-Louise Tangring 2011-08-12 15:36:13 UTC
This should have changed for 5.2. Please re-test to see if issue is still there.

Comment 2 Jeff Slone 2011-08-14 13:26:32 UTC
This feature is fully functional in 5.2. That was not why I filed it. I filed this because it is completely non-functional in version 5.1. This needs to be a back ported fix to 5.1. Working sets are completely non-functional in that version. It is unfair of us to leave 5.1 customers completely in the lurch for this as working sets never functioned correctly in the software they purchased.

Comment 4 Tihomir Surdilovic 2011-08-16 16:23:13 UTC
Changed target version as this does not reflect BRMS 5.2

Comment 5 Lukáš Petrovický 2011-08-22 07:29:56 UTC
Re-assigning to Tiho since there is nothing I could do about this. Once the decision is made, we'll know what to do next.

Comment 6 Tihomir Surdilovic 2011-09-19 12:26:24 UTC
(In reply to comment #2)
> This feature is fully functional in 5.2. That was not why I filed it. I filed
> this because it is completely non-functional in version 5.1. This needs to be a
> back ported fix to 5.1. Working sets are completely non-functional in that
> version. It is unfair of us to leave 5.1 customers completely in the lurch for
> this as working sets never functioned correctly in the software they purchased.

Jeff, we are not going to backport this to 5.1 unless there is a customer request for a one-off patch to 5.1. Can you point me to a BRMS bug from a customer and a support case where this has been requested? If this exists, then sure let's do it, otherwise we will not.

Thanks.

Comment 7 Jeff Slone 2011-09-19 20:44:52 UTC
Tiho - I didn't report this on behalf of a customer. If you'd prefer to wait until a customer reports it, close this one.

Comment 8 lcarlon 2011-09-19 23:28:50 UTC
Marked as no release note needed as this feature wasn't supported in 5.1.


Note You need to log in before you can comment on or make changes to this bug.