Bug 72770 - When resuming from apm both eth0 and eth1 starts...
When resuming from apm both eth0 and eth1 starts...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 13:48 EDT by Richard Torkar
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-22 04:47:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Torkar 2002-08-27 13:48:08 EDT
Description of problem:

(this is a DELL L400 laptop)
eth0 is a built-in 3c905C
eth1 is a wavelan DELL TrueMobile pcmcia card

As default my laptop starts with eth1 on and eth0 off.
When I close the lid on my laptop the apm makes it suspend to ram.
When I open it again everything starts up again - but eth0 starts also...

This means that I have no route to the LAN since eth0 comes before eth1 and eth0
is not connected...

ONBOOT=no for eth0
ONBOOT=yes for eth1

eth0 has a static address set, while eth1 uses dhcp.

How reproducible:
Always

Steps to Reproduce:
1.Close the lid on the laptop
2.Open it up again
3.Voila
	

Actual Results:  eth0 is brought up even since it wasn't up when the laptop was
suspended

Expected Results:  eth0 should not be brought up...
Comment 1 Richard Torkar 2003-02-22 04:47:11 EST
Fixed in Phoebe-3

Note You need to log in before you can comment on or make changes to this bug.