Bug 727731 - WebKit crashes with nspluginwrapper+flash-plugin
Summary: WebKit crashes with nspluginwrapper+flash-plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 04:02 UTC by kentontofte
Modified: 2011-08-31 01:28 UTC (History)
6 users (show)

Fixed In Version: nspluginwrapper-1.4.4-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 20:42:32 UTC


Attachments (Terms of Use)
Backtrace (9.10 KB, text/plain)
2011-08-03 04:02 UTC, kentontofte
no flags Details
NP_Initialize(...) tried to dereference NULL pointer, when cleaning plugin capabilities. (1.53 KB, patch)
2011-08-16 14:44 UTC, Peter Hatina
no flags Details | Diff
Spec file patch. (948 bytes, application/octet-stream)
2011-08-16 14:48 UTC, Peter Hatina
no flags Details

Description kentontofte 2011-08-03 04:02:24 UTC
Created attachment 516426 [details]
Backtrace

Description of problem:
When I click on a link to a Sourceforge webpage, Konqueror crashes. This only happens in the WebKit view mode, not KHTML. 

Version-Release number of selected component (if applicable):
qtwebkit version: 2.2
release: 10.week28.fc16


How reproducible: 
Always

Steps to Reproduce:
1. Open Konqueror
2. In the address bar, type in http://sourceforge.net
3. Under "View" > "View Mode" select "WebKit"

Actual results: 
Crash

Expected results:
Website rendered as normal.

Additional info:
Again, KHTML renders this site without crashing. This only happens in WebKit mode.

Comment 1 Peter Hatina 2011-08-16 14:44:26 UTC
Created attachment 518505 [details]
NP_Initialize(...) tried to dereference NULL pointer, when cleaning plugin capabilities.

Comment 2 Peter Hatina 2011-08-16 14:48:14 UTC
Created attachment 518508 [details]
Spec file patch.

I also attach the patch for a spec file to build nspluginwrapper package, which causes the issue.

Comment 3 Rex Dieter 2011-08-16 14:54:18 UTC
Ah, flash fun. :(

bouncing over the nspluginwrapper for feedback.

Comment 4 Rex Dieter 2011-08-16 17:28:03 UTC
Looks like this is already fixed in nspluginwrapper-1.4.4 upstream where that code is wrapped with

if (plugin_capabilities) {
...
}

vs. this patch's approach of adding
if (plugin_capabilities != NULL ...


I can help work to sync this up to 1.4.4 if that's agreeable.

Comment 5 Fedora Update System 2011-08-17 13:23:22 UTC
nspluginwrapper-1.4.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nspluginwrapper-1.4.4-1.fc16

Comment 6 Fedora Update System 2011-08-17 13:23:31 UTC
nspluginwrapper-1.4.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nspluginwrapper-1.4.4-1.fc15

Comment 7 Fedora Update System 2011-08-17 20:24:47 UTC
Package nspluginwrapper-1.4.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nspluginwrapper-1.4.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nspluginwrapper-1.4.4-1.fc16
then log in and leave karma (feedback).

Comment 8 Rex Dieter 2011-08-19 16:20:57 UTC
fwiw, been experiencing similar symptoms @ work on f14 hosts as well, if there's any chance/interest in an update there too.

Comment 9 Fedora Update System 2011-08-30 20:42:27 UTC
nspluginwrapper-1.4.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-08-31 01:28:09 UTC
nspluginwrapper-1.4.4-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.