This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 727757 - [abrt] kernel: [ INFO: possible recursive locking detected ]
[abrt] kernel: [ INFO: possible recursive locking detected ]
Status: CLOSED DUPLICATE of bug 722472
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:62e77c50c925d5b080066fe0c4c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 02:52 EDT by Mikko Tiihonen
Modified: 2011-08-03 08:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 08:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikko Tiihonen 2011-08-03 02:52:41 EDT
abrt version: 2.0.5
cmdline:        ro root=UUID=10033589-14c8-48f0-8d13-e2b4bf44fce6 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fi rhgb quiet selinux=0 pcie_aspm=force
comment:        The recursive locking bug is always reported on every boot.
kernel:         undefined
reason:         [ INFO: possible recursive locking detected ]
time:           Wed Aug  3 09:34:47 2011

backtrace:
:[ INFO: possible recursive locking detected ]
:3.0.0-3.fc16.x86_64 #1
:---------------------------------------------
:systemd-logind/905 is trying to acquire lock:
: (&ep->mtx){+.+.+.}, at: [<ffffffff8116ee12>] ep_scan_ready_list+0x3a/0x19f
:but task is already holding lock:
: (&ep->mtx){+.+.+.}, at: [<ffffffff8116f38c>] sys_epoll_ctl+0x120/0x51d
:other info that might help us debug this:
: Possible unsafe locking scenario:
:       CPU0
:       ----
:  lock(&ep->mtx);
:  lock(&ep->mtx);
: *** DEADLOCK ***
: May be due to missing lock nesting notation
:2 locks held by systemd-logind/905:
: #0:  (epmutex){+.+.+.}, at: [<ffffffff8116f344>] sys_epoll_ctl+0xd8/0x51d
: #1:  (&ep->mtx){+.+.+.}, at: [<ffffffff8116f38c>] sys_epoll_ctl+0x120/0x51d
:stack backtrace:
:Pid: 905, comm: systemd-logind Not tainted 3.0.0-3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8108a375>] __lock_acquire+0x917/0xcf7
: [<ffffffff8100af3a>] ? dump_trace+0x2fe/0x30d
: [<ffffffff81087a9f>] ? register_lock_class+0x1e/0x2d3
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8108abe2>] lock_acquire+0xbf/0x103
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff81087ea6>] ? save_trace+0x3d/0xa7
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8116e8bf>] ? ep_remove+0xb4/0xb4
: [<ffffffff814dc932>] __mutex_lock_common+0x4c/0x361
: [<ffffffff8116ee12>] ? ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8100e9fd>] ? paravirt_read_tsc+0x9/0xd
: [<ffffffff8108986b>] ? mark_lock+0x2d/0x220
: [<ffffffff8116e8bf>] ? ep_remove+0xb4/0xb4
: [<ffffffff814dcd56>] mutex_lock_nested+0x40/0x45
: [<ffffffff8116ee12>] ep_scan_ready_list+0x3a/0x19f
: [<ffffffff8116ef77>] ? ep_scan_ready_list+0x19f/0x19f
: [<ffffffff8116ef8e>] ep_poll_readyevents_proc+0x17/0x19
: [<ffffffff8116eb9d>] ep_call_nested.constprop.3+0x90/0xcc
: [<ffffffff8116ecc2>] ep_eventpoll_poll+0x4e/0x5d
: [<ffffffff8116f49e>] sys_epoll_ctl+0x232/0x51d
: [<ffffffff8116ea58>] ? ep_set_mstimeout+0x49/0x49
: [<ffffffff814e5002>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 15b822f4-a558-4b8a-a042-160e69127757
:OS: Fedora release 16 (Rawhide)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3986.65
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2001
:System Memory: 16012
:System Swap: 16383
:Vendor: LENOVO
:System: 42844DG ThinkPad W520
:Form factor: Notebook
:Kernel: 3.0.0-3.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:3578:6058:8655) pci, nouveau, VIDEO, GF108 [Quadro 1000M]
:(32902:7247:6058:8655) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4147:404:6058:8655) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7202:6058:8655) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7190:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8655) pci, None, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(4318:3050:6058:8655) pci, None, MULTIMEDIA, GF108 High Definition Audio Controller
:(32902:16952:32902:4369) pci, iwlagn, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(4480:59442:6058:8655) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(4480:59427:6058:8655) pci, sdhci-pci, BASE, N/A
:(32902:7171:6058:8655) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8655) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8655) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:6058:8655) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / btrfs 4096 4096 66967296 35675700 33401130 0 0 0
:/dev/sda1 /boot ext4 4096 4096 2064238 2010337 1905480 524288 524243 524243
:
Comment 1 Josh Boyer 2011-08-03 08:35:42 EDT
This was from a scratch build I did for Mikko to test another bug with.  Unfortunately, it has the same NVR that the official update that fixes this epoll trace has.  That's my mistake.

The next F16 build will contain the fixes for both this and the cdc_ncm bug.

*** This bug has been marked as a duplicate of bug 722472 ***

Note You need to log in before you can comment on or make changes to this bug.