Bug 727765 - Performance regression in video playback
Summary: Performance regression in video playback
Keywords:
Status: CLOSED DUPLICATE of bug 727816
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: spice-qxl-xddm
Version: ---
Hardware: Unspecified
OS: Windows
unspecified
high
Target Milestone: rc
: ---
Assignee: Alon Levy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 07:33 UTC by Lubos Kocman
Modified: 2019-10-10 13:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 12:41:28 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Lubos Kocman 2011-08-03 07:33:19 UTC
Description of problem:

This is a bug summarizing visible performance regression in video playback. As spiceqa + some feedback from customers:

> So far SPICE seems to be much better especially on You-Tube videos,
> however I did observe a serious digression in .WMV files. I have
> uploaded a 720P video I use for customer demonstrations and testing to
> \\cleo.tlv.redhat.com\public\daves

From my current experience surface-less qxl driver performs better at standard video playbacks. But I'm not sure if it's just surfaces.

Version-Release number of selected component (if applicable):

since surface_aware driver (spice 0.8)

How reproducible:


Steps to Reproduce:
1. connect to a spice powered guest in currently supported 2.2.X environment
2. play video
3. connect to a spice powered guest in our rhevm 3.0 env.
4. goto step 2.

  
Actual results:

the older qxl really performs better 


Expected results:

user should have at least the same video experience as in 2.2

Additional info:

More informations will arrive later

Comment 1 Andrew Cathrow 2011-08-03 12:14:56 UTC
I don't see any version numbers in here
Please can you add the version number for spice client and QXL driver in the guest.
We already know that the new spice driver isn't in rhev-tools iso, so we're probably using the old driver but we need to verify and we know that the user portal had an error where it wasn't pushing out the new client.

So lets update this with versions so we can look at this.
thanks

Comment 2 Lubos Kocman 2011-08-03 12:59:37 UTC
Providing versions:

spice-server-0.8.2-3.el6.x86_64
qemu-kvm-0.12.1.2-2.175.el6.alon2.x86_64
spice-client-0.8.2-1.el6.x86_64
guest tools from ic136

Comment 3 Andrew Cathrow 2011-08-03 13:07:01 UTC
(In reply to comment #2)
> Providing versions:




> spice-server-0.8.2-3.el6.x86_64
> qemu-kvm-0.12.1.2-2.175.el6.alon2.x86_64
> spice-client-0.8.2-1.el6.x86_64

SO this is the Linux client?


> guest tools from ic136
So what's the QXL driver version? IC136 does NOT contain the new spice driver that's only in brew.

Comment 5 Christophe Fergeau 2011-08-04 10:32:34 UTC
I'll have to concur with Andrew, we need extensive information about the specific versions and the OS of all the components if we want to work on the specific bug reported on the mailing list.

There was a very interesting point in this mailing list thread that I haven't seen mentioned here, it is

"The new SPICE Client also produces nearly identical results when connecting
to a 2.2 system that normally worked well with the video posted to Cleo.
(Using Windows Media Player natively). So as far I as I can tell the
regression now exists with the new client."

The client is running Windows 7, the guest Windows XP. What is missing now are the qemu/spice-server versions used in RHEV-M 2.2, and the version numbers of the 2 clients that were used. The version of the QXL driver used would also be useful, I guess it's the one that comes with 2.2

If the video regression can be restricted to a client-side regression, that's a big step forward imo.

Given that the mailing thread is a bit vague at times, I might have misinterpreted some things, please correct me if you think what I describe is wrong.

Lubos, either you want to deal with the regression described by Dave Simmons, or you want to deal with something else *you* observed, I'd rather be as specific as possible and keep this bug focused on what Dave described (or some very similar setup).

Comment 6 Lubos Kocman 2011-08-04 12:41:28 UTC

*** This bug has been marked as a duplicate of bug 727816 ***


Note You need to log in before you can comment on or make changes to this bug.