Bug 727796 - bcma to block wl, b43 and maybe bcrm43xx in kernel 2.6.40
bcma to block wl, b43 and maybe bcrm43xx in kernel 2.6.40
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
RejectedNTH
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 05:16 EDT by Alexei Panov
Modified: 2011-11-09 14:22 EST (History)
13 users (show)

See Also:
Fixed In Version: kernel-3.0.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-21 09:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexei Panov 2011-08-03 05:16:33 EDT
Description of problem:
After kernel updates my wifi-adapter stops working.  I've run lspci -k and see:
07:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
        Subsystem: Askey Computer Corp. Device 7175
        Kernel driver in use: bcma
        Kernel modules: bcma, wl
bcma - Broadcom's specific AMBA driver
This is a normal work of module bcma? I'm not sure what this a bug.
Also I'm read that a bcma module do block b43 too.

Version-Release number of selected component (if applicable):
2.6.40

How reproducible:
always

Steps to Reproduce:
1. Update kernel with bcm wifi adapter
  
Actual results:
bcma loaded instead wl, b43

Expected results:
wl or b43 to load instead bcma

Additional info:
I've add bcma to blacklist of modules.
My wifi-adapter doesn't work with free and open-source modules, only with wl.

$ lspci -vnnn
07:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g LP-PHY [14e4:4727] (rev 01)

My main question - this is a bug or not?
Thanks.
Comment 1 John W. Linville 2011-08-03 13:47:07 EDT
Well, it is 'working as designed' -- it is just that the b43 driver in that kernel doesn't support your device.  So it is a bit useless to let bcma claim the hardware.

I'll disable CONFIG_BCMA.
Comment 2 Alexei Panov 2011-08-03 14:08:26 EDT
Thank you very much, John.
Comment 3 Alexei Panov 2011-08-03 15:14:30 EDT
I've compiled brcm80211 as standalone kernel module, and bcma block it too.
I think it might be interesting or useful to you.
Comment 4 Rafael Louback Ferraz 2011-08-05 13:40:18 EDT
same thing on bcm43224 14e4:4353 (rev 01)
Comment 5 Tim Flink 2011-08-05 15:20:03 EDT
Discussed in the 2011-08-05 blocker review meeting. Rejected as NTH [1] for Fedora 16 alpha because impact is only one four particular broadcom wireless adapters that don't work our of the box in fedora anyway, can be worked around or fixed with a post-install kernel update.

[1] http://fedoraproject.org/wiki/QA:SOP_nth_bug_process
Comment 6 Fedora Update System 2011-08-08 20:04:44 EDT
kernel-3.0.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
Comment 7 Fedora Update System 2011-08-08 22:53:16 EDT
Package kernel-3.0.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.0.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
then log in and leave karma (feedback).
Comment 8 Alexei Panov 2011-08-09 06:37:17 EDT
kernel 3.0.1-3.fc16.x86_64

$ modinfo bcma
ERROR: modinfo: could not find module bcma

Yep, thanks!

P.S. I've added karma.
Comment 9 Rafael Louback Ferraz 2011-08-09 10:51:30 EDT
in kernel 3.0 is supposed to b43 handle this kind of wireless card?
Comment 10 John W. Linville 2011-08-09 11:44:02 EDT
No.
Comment 11 Muayyad Alsadi 2011-08-10 18:26:46 EDT
how about pushing 2.6.40 update for fedora 15 testing too
Comment 12 Fedora Update System 2011-08-16 08:46:53 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 13 Fedora Update System 2011-08-17 22:29:48 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Muayyad Alsadi 2011-08-20 12:09:38 EDT
please apply this same fix for f15
Comment 15 Rafael Louback Ferraz 2011-08-20 19:09:28 EDT
is working in kernel-2.6.40.3-0.fc15!

thanks
Comment 16 Josh Boyer 2011-08-21 09:01:03 EDT
(In reply to comment #14)
> please apply this same fix for f15

It has been.  See comment #13.
Comment 17 Stephen Phillips 2011-08-22 10:08:43 EDT
I had issues with a slightly different wireless version:


$ echo 'Kernel Version: ' `uname -r` && echo 'lspci Info:' && lspci -v | awk '/Ether|Net/,/^$/'
Kernel Version:  2.6.40-4.fc15.x86_64
lspci Info:
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
	Subsystem: Dell Device 01f2
	Flags: bus master, fast devsel, latency 64, IRQ 17
	Memory at fe5fe000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: b44
	Kernel modules: b44

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
	Subsystem: Dell Wireless 1395 WLAN Mini-Card
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at fe8fc000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: wl
	Kernel modules: wl, ssb


I am not sure if this is normal or not, but I had to install kmod-wl-2.6.40-4 for it to work with this kernel.  Even so, this morning when I booted up, it didn't work again.  After several reboots and trying the different kernel versions from the Grub menu it just started working again.

I thought yum had upgraded the kernel a couple of times up to the 2.6.38 kernel version without any problems.  I don't remember having to go back to yum and install the kmod-wl version for the new kernel.  Ever since version 2.6.40-4 and 2.6.40.3 it wouldn't work.  Now, it works, but it seems hit or miss.

I tried to blacklist bcma, but that didn't help.  I don't think I have that module installed.
Comment 18 Fedora Update System 2011-08-22 10:50:08 EDT
kernel-3.0.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 David Woodhouse 2011-11-08 18:30:48 EST
Can we have bcma enabled again please; I'd like to be able to use my bcm4331 in F16. People who want to use illegal modules can always blacklist the bcma module.
Comment 20 John W. Linville 2011-11-09 13:16:03 EST
Alternatively, we could enable the brcm80211 driver in the kernel...
Comment 21 Peter Lemenkov 2011-11-09 13:47:53 EST
(In reply to comment #20)
> Alternatively, we could enable the brcm80211 driver in the kernel...

Yes, that sounds reasonable now. It has been promoted from staging to main recently so there is no any non-technical reasons to disable it.

However I 'm not sure whether b43 and brcm80211 have overlapping supported PCI IDs or not. This could be a problem then.
Comment 22 David Woodhouse 2011-11-09 14:22:56 EST
bcrm82011 doesn't support the BCM4331. Only b43 does.

Note You need to log in before you can comment on or make changes to this bug.