Bug 727799 - virtio-win: viostor on 2008 x64 is unsigned
Summary: virtio-win: viostor on 2008 x64 is unsigned
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 6.2
Assignee: Jay Greguske
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 730363
TreeView+ depends on / blocked
 
Reported: 2011-08-03 09:22 UTC by Ofer Schreiber
Modified: 2011-12-06 21:17 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document.
Clone Of:
: 730363 (view as bug list)
Environment:
Last Closed: 2011-12-06 21:17:46 UTC


Attachments (Terms of Use)
2008R2 pop up (47.48 KB, image/jpeg)
2011-08-03 09:22 UTC, Ofer Schreiber
no flags Details
blue screen (55.54 KB, image/png)
2011-08-07 13:34 UTC, Idan Mansano
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1542 normal SHIPPED_LIVE virtio-win bug fix update 2011-12-07 02:13:14 UTC

Description Ofer Schreiber 2011-08-03 09:22:33 UTC
Created attachment 516470 [details]
2008R2 pop up

Description of problem:
Installing viostor on 2008R2 and 2008 x64 pops up error message

Version-Release number of selected component (if applicable):
virtio-win-1.3.1-1.el6.noarch

How reproducible:
Install viostor drivers on 2008R2 or 2008 x64 machine, using device manager

Additional info:
Not sure if that's the actual issue, but the sys + inf files are identical between Win7 and Win2008, but the cat file is different

[root@white-rhevmb amd64]# pwd
/usr/share/virtio-win/drivers/amd64
[root@white-rhevmb amd64]# md5sum Win7/* |grep viostor
c3fc3731d19f9ed2ebcfa910bfe79c64  Win7/viostor.cat
e967073754dc151b383e17202d8715d0  Win7/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win7/viostor.sys
[root@white-rhevmb amd64]# md5sum Win2008/* |grep viostor
eb660764f58bd73afe26d229a5242f6c  Win2008/viostor.cat
e967073754dc151b383e17202d8715d0  Win2008/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win2008/viostor.sys

Comment 6 Mike Cao 2011-08-04 08:33:05 UTC
Reproduced on virtio-win-1.3.1-1.el6 ,Verified on virtio-win-1.3.1-2.el6

steps same as comment #0

Actual Results:
on virtio-win-1.3.1-1.el6 ,it prompts "driver is un-signed“
on virtio-win-1.3.1-2.el6 ,it shows "driver is digital signed”

based on above ,this issue has been fixed ,move status to VERIFIED.

Comment 7 Ofer Schreiber 2011-08-04 09:10:28 UTC
Although the right drivers seems to be after installing the RPM, it seems that the virtio-win-1.3.1-bin-whql.zip file inside the src is not updated, and still causing the error massage.

We're extracting this zip from the src during the brew-win build of the RHEV-Block64 msi in order to get the drivers (as suggested by Mike).


Logs:

[build@paradise amd64]$ rpm -q  virtio-win
virtio-win-1.3.1-1.el6.noarch
[build@paradise amd64]$ md5sum Win7/* | grep viost
c3fc3731d19f9ed2ebcfa910bfe79c64  Win7/viostor.cat
e967073754dc151b383e17202d8715d0  Win7/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win7/viostor.sys
[build@paradise amd64]$ md5sum Win2008/* | grep viost
eb660764f58bd73afe26d229a5242f6c  Win2008/viostor.cat
e967073754dc151b383e17202d8715d0  Win2008/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win2008/viostor.sys

[build@paradise amd64]$ rpm -q  virtio-win
virtio-win-1.3.1-2.el6.noarch
[build@paradise amd64]$ md5sum Win7/* | grep viost
c3fc3731d19f9ed2ebcfa910bfe79c64  Win7/viostor.cat
e967073754dc151b383e17202d8715d0  Win7/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win7/viostor.sys
[build@paradise amd64]$ md5sum Win2008/* | grep viost
b8be648ac21dae9420ba9200533f5150  Win2008/viostor.cat
e967073754dc151b383e17202d8715d0  Win2008/viostor.inf
d4abe97c6359650b7aad6067ae3747a7  Win2008/viostor.sys

After extracting virtio-win-1.3.1-bin-whql.zip from virtio-win-1.3.1-2.el6.src.rpm (using rpm2cpio):
[build@paradise games]$ md5sum virtio-win-1.3.1/viostor/2k8/amd64/*
eb660764f58bd73afe26d229a5242f6c  virtio-win-1.3.1/viostor/2k8/amd64/viostor.cat
e967073754dc151b383e17202d8715d0  virtio-win-1.3.1/viostor/2k8/amd64/viostor.inf
c53a61334debfa9d1748dc47f12f6e6a  virtio-win-1.3.1/viostor/2k8/amd64/viostor.pdb
d4abe97c6359650b7aad6067ae3747a7  virtio-win-1.3.1/viostor/2k8/amd64/viostor.sys

which is the same as virtio-win-1.3.1-1.el6.noarch

Comment 8 Mike Cao 2011-08-04 10:27:19 UTC
Reproduced senario in comment #7 and sorry for did not test src rpm package .
What I know before is that we use src package to build package.this is the first time I know we can use source files directly.

I tried use the source to build noarch rpm package & src package

steps:
1.rpm -ivh virtio-win-1.3.1-2.el6.src.rpm
2.cd /root/rpmbuild
3.rpmbuild -ba virtio-win.spec

after step3 ,it will make virtio-win-1.3.1-2.el6.noarch.rpm & virtio-win-1.3.1-2.el6.src.rpm

I installed the noarch rpm built by myself ,md5 of each file 
 md5sum *
b8be648ac21dae9420ba9200533f5150  viostor.cat
e967073754dc151b383e17202d8715d0  viostor.inf
c53a61334debfa9d1748dc47f12f6e6a  viostor.pdb
d4abe97c6359650b7aad6067ae3747a7  viostor.sys

while installed src rpm built by myself and extracting this zip from the src  will hit the issue described in comment #7.

Comment 11 Mike Cao 2011-08-05 05:38:47 UTC
I conpared all the md5sum in  virtio-win-1.3.1-bin-whql.zip and virtio-win-1.3.2.iso ,all the md5sum of the files with same name are same .

But I hit another new issue .

steps:
1.rpm -ivh ~/urgent/virtio-win-1.3.2-1.el6.src.rpm
2.cd /root/rpmbuild/SOURCES
3.unzip virtio-win-1.3.2.zip 

Actual Resutls:
It extracts to a new directory named  "virtio-win-1.3.1"

Expected Results:
it should be :virtio-win-1.3.2

bcao--->mikeb@redhat.com

Hi ,Mike Bonnet

Could you view my comment above ,and whether it is bug ?

Comment 14 Idan Mansano 2011-08-07 11:31:34 UTC
I installed latest tools.
It seems like the problem is now fixed.

Comment 15 Idan Mansano 2011-08-07 13:34:19 UTC
Created attachment 517048 [details]
blue screen

Comment 16 Idan Mansano 2011-08-07 13:35:23 UTC
the print screen above is mistakenly uploaded
please ignore

Comment 17 Mike Cao 2011-08-08 03:34:39 UTC
(In reply to comment #13)
> The path in the source .zip has been fixed in virtio-win-1.3.2-2.el6.  There
> are no other changes to the zips/rpms.

Hi ,Mike Bonnet

as your words ,there are no other changes to the zips/rpms ,But I found that the md5sum of virtio-win-1.3.2.iso btween virtio-win-1.3.2-2.el6 and virtio-win-1.3.2-1.el6 are not same 

#rpm -ivh virtio-win-1.3.2-1.el6.noarch.rpm
#md5sum /usr/share/virtio-win/virtio-win-1.3.2.iso
f99068b2636ce8edd3b9ae37188456e2  /usr/share/virtio-win/virtio-win-1.3.2.iso

#rpm -ivh virtio-win-1.3.2-2.el6.noarch.rpm
# md5sum /usr/share/virtio-win/virtio-win-1.3.2.iso 
67cd9753cf15ce7947721acfec8b0cef  /usr/share/virtio-win/virtio-win-1.3.2.iso

while I check all the md5sum of file located in  virtio-win-1.3.2.iso between 2 versions ,I found nothing changed .Then I was confused about why the 2 isos md5 are not same .

Could you clarify this ?

thanks

Comment 18 Mike Bonnet 2011-08-08 14:40:56 UTC
The only differences between the isos are the timestamps of a few directories.  I mounted both isos and run a recursive diff between them, and no file differences were found.

Comment 19 Mike Cao 2011-08-09 05:56:47 UTC
Verified on  virtio-win-1.3.2-2.el6 with the steps in comment#0 


Actual Results:
all driver signed .

additional info:
QE compared all the md5 of the file installed from virtio-win-1.3.2-2.el6 and virtio-win-1.3.2-1.el6  .and for the file in virtio-win-1.3.2-1.el6 .use signTool.exe to confirmed that all the driver was signed


Based on above ,this issue has been fixed .move status to verified.

Comment 20 Vadim Rozenfeld 2011-11-02 20:10:08 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document.

Comment 21 Mike Cao 2011-11-21 04:50:23 UTC
*** Bug 730363 has been marked as a duplicate of this bug. ***

Comment 22 errata-xmlrpc 2011-12-06 21:17:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1542.html


Note You need to log in before you can comment on or make changes to this bug.