Bug 727802 - ATI Redwood (Radeon HD 5600) incorrectly blacklisted
Summary: ATI Redwood (Radeon HD 5600) incorrectly blacklisted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 09:31 UTC by Michel Alexandre Salim
Modified: 2012-02-02 15:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-02 15:24:14 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2011-08-03 09:31:19 UTC
Description of problem:
With F-15's gnome-session-3.0.1-2.fc15, gnome-session spawns gnome-shell just fine. After upgrading to the F-16 pre-alpha, however, I get to the fallback mode instead, with a notification box saying my graphics card is not supported.

Manually invoking 'gnome-shell --replace' starts it just fine.

Version-Release number of selected component (if applicable):

gnome-session-3.1.3-1.fc16.x86_64
gnome-shell-3.1.4-1.fc16.x86_64
mesa-dri-drivers-7.11-1.fc16.x86_64
xorg-x11-drv-ati-6.14.2-1.20110727git8c9266ed2.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to F-16
2. Log in
  
Actual results:
Starts in fallback mode. ~/.xsession-errors contains

  gnome-session[2992]: WARNING: Session 'gnome' runnable check failed: Exited with code 1

Expected results:
GNOME Shell should be started

Additional info:
Relevant lspci -vv section:


01:00.0 VGA compatible controller: ATI Technologies Inc Redwood [Radeon HD 5600 Series] (prog-if 00 [VGA controller])
        Subsystem: Sony Corporation Device 9071
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 42
        Region 0: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at f0020000 (64-bit, non-prefetchable) [size=128K]
        Region 4: I/O ports at d000 [size=256]
        Expansion ROM at f0000000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: radeon
        Kernel modules: radeon

Comment 1 Michel Alexandre Salim 2011-08-03 22:21:43 UTC
Per https://bugzilla.redhat.com/show_bug.cgi?id=712785:

$ /usr/libexec/gnome-session-check-accelerated ; echo $?
1
$ /usr/libexec/gnome-session-check-accelerated-helper ; echo $?
0

I am running a custom 3.0.0 kernel, but the configuration is based on the F-15 kernel, and before updating to F-16 pre-alpha gnome-session happily enables GNOME Shell.

Comment 2 Michel Alexandre Salim 2011-08-05 11:40:27 UTC
Removing the X property and retrying gnome-session-check-accelerated works, so it's not a gnome-session bug.

Turns out to be the recently-fixed GDM issue:

* Wed Aug 03 2011 Lennart Poettering <lpoetter@redhat.com> - 1:3.1.2-4
- Register welcome pseudo-session in PAM

https://admin.fedoraproject.org/updates/udev-173-1.fc16,gdm-3.1.2-4.fc16,systemd-33-1.fc16?_csrf_token=5d60e0c5aa4eff9fef6b054046edc529f88c9021


Note You need to log in before you can comment on or make changes to this bug.