Bug 727837 - Failed to install bootloader by kickstart install
Summary: Failed to install bootloader by kickstart install
Keywords:
Status: CLOSED DUPLICATE of bug 727679
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 11:31 UTC by He Rui
Modified: 2011-08-03 14:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 14:01:54 UTC


Attachments (Terms of Use)
error screen (38.10 KB, image/png)
2011-08-03 11:31 UTC, He Rui
no flags Details
/tmp/* files (56.32 KB, application/x-gzip)
2011-08-03 11:33 UTC, He Rui
no flags Details

Description He Rui 2011-08-03 11:31:11 UTC
Created attachment 516497 [details]
error screen

Description of problem:
Virt-installed F16 alpha tc1 by kickstart, but it failed to install bootloader. It's probably because it uses GPT partitioning table as default, but BIOS boot is not specified in the kickstart.

The partitioning and bootloader is like this:
# Specifies how the GRUB boot loader should be installed
bootloader --location mbr
# Removes partitions from the system, prior to creation of new partitions
clearpart --all --initlabel
part /boot --fstype ext4 --size 500
part /     --fstype ext4 --size 5000
part swap --fstype swap --size 500

Version-Release number of selected component (if applicable):
anaconda 16.14
16 alpha tc1

How reproducible:
100%

Steps to Reproduce:
1.boot with kickstart like the above


Expected results:
install without error

Additional info
How can I configure to have msdos partition table?

Comment 1 He Rui 2011-08-03 11:33:37 UTC
Created attachment 516498 [details]
/tmp/* files

Comment 2 Chris Lumens 2011-08-03 14:01:54 UTC

*** This bug has been marked as a duplicate of bug 727679 ***


Note You need to log in before you can comment on or make changes to this bug.