Bug 727860 - [abrt] system-config-printer-1.3.3-1.fc15: pickle.py:858:load:KeyError: '['
Summary: [abrt] system-config-printer-1.3.3-1.fc15: pickle.py:858:load:KeyError: '['
Keywords:
Status: CLOSED DUPLICATE of bug 722992
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:971c402debc9cdb08176b5ad0e9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 12:59 UTC by Kelvan
Modified: 2011-08-03 13:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 13:32:33 UTC


Attachments (Terms of Use)

Description Kelvan 2011-08-03 12:59:22 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
comment:        just clicked on new printer and authorize sudo rights
component:      system-config-printer
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         2.6.38.8-35.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        system-config-printer-1.3.3-1.fc15
reason:         pickle.py:858:load:KeyError: '['
time:           Wed Aug  3 14:56:39 2011
uid:            1000
username:       kelvan

backtrace:
:pickle.py:858:load:KeyError: '['
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
:    reply_handler(*message.get_args_list(**get_args_opts))
:  File "/usr/share/system-config-printer/firewall.py", line 77, in reply_handler
:    self._fw_data = pickle.loads (result.encode ('utf-8'))
:  File "/usr/lib64/python2.7/pickle.py", line 1382, in loads
:    return Unpickler(file).load()
:  File "/usr/lib64/python2.7/pickle.py", line 858, in load
:    dispatch[key](self)
:KeyError: '['
:
:Local variables in innermost frame:
:read: <built-in method read of cStringIO.StringI object at 0x1a19180>
:self: <pickle.Unpickler instance at 0x1a1fc20>
:dispatch: {'': <function load_eof at 0x12f9b18>, '\x80': <function load_proto at 0x12f9b90>, '\x83': <function load_ext2 at 0x12fac80>, '\x82': <function load_ext1 at 0x12fac08>, '\x85': <function load_tuple1 at 0x12fa668>, '\x84': <function load_ext4 at 0x12facf8>, '\x87': <function load_tuple3 at 0x12fa758>, '\x86': <function load_tuple2 at 0x12fa6e0>, '\x89': <function load_false at 0x12f9d70>, '\x88': <function load_true at 0x12f9de8>, '\x8b': <function load_long4 at 0x12fa1b8>, '\x8a': <function load_long1 at 0x12fa140>, '\x81': <function load_newobj at 0x12fab18>, ')': <function load_empty_tuple at 0x12fa5f0>, '(': <function load_mark at 0x12fb5f0>, '.': <function load_stop at 0x12fb668>, '1': <function load_pop_mark at 0x12faf50>, '0': <function load_pop at 0x12faed8>, '2': <function load_dup at 0x12fb050>, 'G': <function load_binfloat at 0x12fa2a8>, 'F': <function load_float at 0x12fa230>, 'I': <function load_int at 0x12f9e60>, 'K': <function load_binint1 at 0x12f9f50>, 'J': <function load_binint at 0x12f9ed8>, 'M': <function load_binint2 at 0x12fa050>, 'L': <function load_long at 0x12fa0c8>, 'N': <function load_none at 0x12f9cf8>, 'Q': <function load_binpersid at 0x12f9c80>, 'P': <function load_persid at 0x12f9c08>, 'S': <function load_string at 0x12fa320>, 'R': <function load_reduce at 0x12fae60>, 'U': <function load_short_binstring at 0x12fa500>, 'T': <function load_binstring at 0x12fa398>, 'V': <function load_unicode at 0x12fa410>, 'X': <function load_binunicode at 0x12fa488>, ']': <function load_empty_list at 0x12fa7d0>, 'a': <function load_append at 0x12fb398>, 'c': <function load_global at 0x12fab90>, 'b': <function load_build at 0x12fb578>, 'e': <function load_appends at 0x12fb410>, 'd': <function load_dict at 0x12fa938>, 'g': <function load_get at 0x12fb0c8>, 'i': <function load_inst at 0x12faa28>, 'h': <function load_binget at 0x12fb140>, 'j': <function load_long_binget at 0x12fb1b8>, 'l': <function load_list at 0x12fa8c0>, 'o': <function load_obj at 0x12faaa0>, 'q': <function load_binput at 0x12fb2a8>, 'p': <function load_put at 0x12fb230>, 's': <function load_setitem at 0x12fb488>, 'r': <function load_long_binput at 0x12fb320>, 'u': <function load_setitems at 0x12fb500>, 't': <function load_tuple at 0x12fa578>, '}': <function load_empty_dictionary at 0x12fa848>}
:key: '['

Comment 1 Tim Waugh 2011-08-03 13:32:33 UTC
This is due to an API change in the system-config-firewall D-Bus service.

*** This bug has been marked as a duplicate of bug 722992 ***


Note You need to log in before you can comment on or make changes to this bug.