Bug 72787 - Anaconda hangs on Dell PowerEdge 1650 after monitor probe
Anaconda hangs on Dell PowerEdge 1650 after monitor probe
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 16:20 EDT by Bill Rugolsky, Jr.
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 16:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Rugolsky, Jr. 2002-08-27 16:20:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
While attempting to install on a Dell PowerEdge 1650, anaconda hangs after
printing and logging the "Probing for monitor type:" message at line 417.  The
card and monitor probe correctly.  Anaconda appears to be hanging at the keymap
handling at lines 419-421, as it never prints the mouse probe message.  I can
switch to the other virtual consoles and the shell on VC 2 is functional.  A ps
just shows anaconda (pid 11) sleeping. (Is there an easy way to get a python
trace?) Anaconda dies when signalled from VC 2.

The machine has a Dell keyboard and 2-button mouse, an NEC Multisync LCD1530V
(which is correctly probed), 512MB of RAM, and two Hitachi 18GB SCSI drives.   
Default English (US) install.  Tried it with another monitor, same result. 
Tried it with combinations of text/noprobe/skipddc, same result. (BTW, why do we
probe the video card and monitor in text mode?)

Red Hat 7.3 installs fine.  The Null kernel also works fine under
under 7.3.  The Null CDs pass the mediacheck and have been used to
install on my laptop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot Null from CD-ROM.
2.English (US) install.
3.Skip or don't skip mediacheck.

	

Actual Results:  Anaconda hangs near lines 419-421 while manipulating the keyboard.

Additional info:
Comment 1 Michael Fulbright 2002-08-27 16:38:56 EDT
On VC2 try this:

python -c "import kudzu; print
kudzu.probe(kudzu.CLASS_KEYBOARD,kudzu.BUS_UNSPEC,                          
kudzu.PROBE_ONE)"

Comment 2 Bill Rugolsky, Jr. 2002-08-27 16:54:38 EDT
python printed a single blank line.
Comment 3 Bill Rugolsky, Jr. 2002-10-01 11:49:17 EDT
The hang occured because console redirection was enabled in the BIOS.  Turning
this off, Anaconda starts with the Red Hat 8.0 installation CD.

Sorry for the noise ...


Note You need to log in before you can comment on or make changes to this bug.