Bug 727901 - Update produces an error message
Summary: Update produces an error message
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 15:15 UTC by darrell pfeifer
Modified: 2015-02-18 13:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 13:36:29 UTC


Attachments (Terms of Use)

Description darrell pfeifer 2011-08-03 15:15:31 UTC
Description of problem:

On update the following messages appear:

warning: /etc/selinux/targeted/modules/active/policy.kern created as /etc/selinux/targeted/modules/active/policy.kern.rpmnew
libsemanage.semanage_fc_sort: WARNING: semanage_fc_sort: Incomplete context.

I've also never updated policy.kern. There is no policy.kern.rpmnew after the update is complete.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Walsh 2011-08-03 17:26:56 UTC
If you have modified policy at all you will see this error.  The semanage_fc_sort is an actual bug.

Comment 2 darrell pfeifer 2011-08-03 18:47:55 UTC
As I said in the description, I've never modified the policy (or generally run with selinux on, except for the current problem with selinux=0 not working) so that's why I was surprised to see the rpmnew.

Comment 3 Daniel Walsh 2011-08-03 19:39:43 UTC
Ok I guess this is an upgrade which could also cause the problem.

Just move the rpmnew package over the old one and then you should not see the problem any more.

What we are trying to do now is provide for quicker selinux policy updates.

mv
/etc/selinux/targeted/modules/active/policy.kern.rpmnew
 /etc/selinux/targeted/modules/active/policy.kern 

Then the update of selinux-policy should go much quicker until you modify the policy.

Comment 4 darrell pfeifer 2011-08-03 19:47:11 UTC
Back again to my comment in the original bug report. That's exactly what I would have done, but there is no rpmnew file left in that directory, so nothing to mv

Comment 5 Daniel Walsh 2011-08-03 19:49:39 UTC
Ok, try

rm /etc/selinux/targeted/modules/active/policy.kern
yum reinstall selinux-policy-targeted

And see if the problem goes away.

Comment 6 darrell pfeifer 2011-08-03 20:00:39 UTC
I did the reinstall first (before the rm) just to see if the rpmnew message reappeared. It didn't.

Tried the reinstall another time without the rm and still no message.

At this point can't reproduce so will wait for the next update.

This bug can be closed when the fc_sort error is fixed.

Comment 7 Daniel Walsh 2011-08-04 17:56:23 UTC
The first time you update from an older policy to the new you will see this message, then as long as you don't modify anything you should not see the message again.  If you modify anything you will see the message :^(  I wish we could get rid of the message since all we want to do is key off this file as being modified or not.

Comment 8 darrell pfeifer 2011-08-04 22:18:49 UTC
Yes, updated to selinux-policy-3.10.0-16 and the rpmnew message reappeared.

I've been updating almost daily for a very long time. I've never seen a circumstance where a message said an rpmnew file was being created and there wasn't one. There has got to be a way to prevent this. Of all the packages I'd want to install clean, a security package is one, and a security package that installs saying it will produce a file then not doing so leaves me really worried.

The fc-sort error is gone.

Comment 9 Daniel Walsh 2011-08-05 13:29:27 UTC
Ok, how about I

Comment 10 Daniel Walsh 2011-08-05 14:07:14 UTC
I think I have found a better way.  We are currently shipping a md5sum file with the policy.  In the rpm pre I can check to see if the 
/usr/share/selinux/targeted/.md5sum |= md5sum policy.kern
and put a flag out to rebuild the policy.  On systems that do not have
/usr/share/selinux/targeted/.md5sum I will always rebuild.

Then on the next update it will have the file and check, as long as the user has the default policy, the package should not rebuild but just install the policy.

Comment 11 Fedora End Of Life 2013-04-03 19:33:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 12 Fedora End Of Life 2015-01-09 21:51:42 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 13 Fedora End Of Life 2015-02-18 13:36:29 UTC
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.