Bug 727924 - kernel-2.6.40-4.fc15.x86_64 seems to break virtbrX interfaces for IPv6
kernel-2.6.40-4.fc15.x86_64 seems to break virtbrX interfaces for IPv6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 12:54 EDT by Trever Adams
Modified: 2012-09-12 10:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 10:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2011-08-03 12:54:30 EDT
Description of problem:
Starting with a reboot with this kernel yesterday, I am seeing a problem I have never seen before. radvd now gives "error parsing or activating the config file: /var/lib/libvirt/radvd/XXX-radvd.conf"

I can manually start radvd with "radvd -C /var/lib/libvirt/radvd/XXX-radvd.conf -p /var/run/radvd/XXX-radvd.pid"

I also see: "radvd[2478]: interface virbr0 is not RUNNING
radvd[2478]: interface virbr0 does not exist
radvd[2555]: no linklocal address configured for virbr1" and the like.

All of my vms are kvm/qemu not xen. The last libvirt/qemu changes in my yum log are from over a month ago (at least one reboot since then with no problems until the reboot for the 2.6.40 kernel package).


Version-Release number of selected component (if applicable):
kernel-2.6.40-4.fc15.x86_64
Comment 1 Trever Adams 2011-10-14 10:15:35 EDT
This appears to be in F16 3.1.x kernels as well. It may be related to bug #744814.
Comment 2 Trever Adams 2012-04-03 15:36:18 EDT
This is far better than it has ever been, but still occasionally happens on F16 with latest kernels.
Comment 3 Josh Boyer 2012-09-05 12:37:42 EDT
Are you still seeing this with 3.4.9?
Comment 4 Trever Adams 2012-09-07 10:14:41 EDT
I have seen it with some 3.4.x and 3.5.x kernels. It is getting more and more rare. If this isn't readily clear, ignore it (but please don't close it) for now unless I post that it has happened again. This was happening in F17. The last few kernels MAY have fixed it.
Comment 5 Trever Adams 2012-09-12 09:09:21 EDT
I haven't seen this in several reboots. You can close it if you wish.

Note You need to log in before you can comment on or make changes to this bug.