Bug 727954 - matahari agents core dump w/ sigar-1.6.5-0.2.git58097d9
Summary: matahari agents core dump w/ sigar-1.6.5-0.2.git58097d9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 6.2
Assignee: Adam Stokes
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 18:56 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
4 users (show)

Fixed In Version: matahari-0.4.2-4.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:15 UTC


Attachments (Terms of Use)
core dump (12.02 MB, application/octet-stream)
2011-08-03 18:56 UTC, Dave Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-03 18:56:45 UTC
Created attachment 516564 [details]
core dump

Description of problem:
Setup a kerberos server and configured the matahari broker/agents to authenticate through it.  The broker would startup but when the agents where started, they always segfaulted.  

Version-Release number of selected component (if applicable):
matahari-0.4.2-2.el6.x86_64
matahari-agent-lib-0.4.2-2.el6.x86_64
matahari-broker-0.4.2-2.el6.x86_64
matahari-host-0.4.2-2.el6.x86_64
matahari-lib-0.4.2-2.el6.x86_64
matahari-network-0.4.2-2.el6.x86_64
matahari-service-0.4.2-2.el6.x86_64
matahari-sysconfig-0.4.2-2.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.  configure matahari broker/agents to use kerberos
2.  start broker
3.  start matahari agent
  
Actual results:
agent seg faults

Expected results:
agent connects to broker

Comment 2 Dave Johnson 2011-08-03 19:16:01 UTC
I should have also attached this which is in /var/log/messages when the seg fault occurs:

Aug  3 15:08:37 ibm-crichton-02 host[4802]: int MatahariAgent::init(int, char**, const char*): Connecting host to Qpid broker at amqp:tcp:127.0.0.1:49000
Aug  3 15:08:37 ibm-crichton-02 kernel: matahari-qmf-ho[4802]: segfault at 148 ip 00007fc62d6ec354 sp 00007fffc82dfea0 error 4 in libsigar.so[7fc62d6dd000+1e000]
Aug  3 15:08:37 ibm-crichton-02 abrt[4806]: saved core dump of pid 4802 (/usr/sbin/matahari-qmf-hostd) to /var/spool/abrt/ccpp-2011-08-03-15:08:37-4802.new/coredump (12480512 bytes)
Aug  3 15:08:37 ibm-crichton-02 abrtd: Directory 'ccpp-2011-08-03-15:08:37-4802' creation detected
Aug  3 15:08:37 ibm-crichton-02 abrtd: Package 'matahari-host' isn't signed with proper key
Aug  3 15:08:37 ibm-crichton-02 abrtd: Corrupted or bad dump /var/spool/abrt/ccpp-2011-08-03-15:08:37-4802 (res:2), deleting

Comment 3 Dave Johnson 2011-08-04 17:36:36 UTC
Disregard everything in the original comment...this has nothing to do with Kerberos integration.  I inadvertently smoke tested the brew rpms on a RHEL 6.1 server and then began immediate testing of kerberos intergration using RHEL 6.2.

The problem is sigar-1.6.5-0.2.git58097d9 which is install with RHEL 6.2 nightly builds.  If you go back to RHEL 6.1, the brew rpms work as expected.  If you upgrade sigar on RHEL 6.1 to use sigar-1.6.5-0.2.git58097d9, seg faults begin happening.

Comment 4 Andrew Beekhof 2011-08-10 11:58:35 UTC
We've gotten sigar-1.6.5-0.2.git58097d9 tagged into the buildroot and made sure matahari was built against it.  Should be good to go now.

Comment 6 Dave Johnson 2011-08-16 22:11:57 UTC
Good to with v0.4.2-6

Comment 7 Russell Bryant 2011-11-16 21:19:01 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 8 errata-xmlrpc 2011-12-06 11:39:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.