Bug 727961 - RFE: matahari agent reconnect too verbose
Summary: RFE: matahari agent reconnect too verbose
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 19:19 UTC by Dave Johnson
Modified: 2016-04-26 14:13 UTC (History)
3 users (show)

Fixed In Version: matahari-0.4.2-4.el6
Doc Type: Enhancement
Doc Text:
No description needed
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-03 19:19:38 UTC
Description of problem:

If the agent is configured to reconnect to the broker and keep trying until it does (which is the default), two messages are printed to /var/log/messages each second, seems a little verbose to me.  Just floating the possibility of only printing out a reconnect attempt message ever 30?-60?-300? seconds.

Aug  3 15:06:49 ibm-crichton-02 host[4561]: int MatahariAgent::init(int, char**, const char*): Trying DNS SRV
Aug  3 15:06:49 ibm-crichton-02 host[4561]: int MatahariAgent::init(int, char**, const char*): Trying qpid broker 127.0.0.1 again
Aug  3 15:06:50 ibm-crichton-02 host[4561]: int MatahariAgent::init(int, char**, const char*): Trying DNS SRV
Aug  3 15:06:50 ibm-crichton-02 host[4561]: int MatahariAgent::init(int, char**, const char*): Trying qpid broker 127.0.0.1 again


Version-Release number of selected component (if applicable):
matahari-0.4.2-2.el6.x86_64
matahari-agent-lib-0.4.2-2.el6.x86_64
matahari-broker-0.4.2-2.el6.x86_64
matahari-host-0.4.2-2.el6.x86_64
matahari-lib-0.4.2-2.el6.x86_64
matahari-network-0.4.2-2.el6.x86_64
matahari-service-0.4.2-2.el6.x86_64
matahari-sysconfig-0.4.2-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  install matahari agents
2.  without a local broker (and no config for a remote one), start a matahari agent
3.  tail -f /var/log/messages
  
Actual results:
2 log statements each second

Expected results:


Additional info:

Comment 2 Andrew Beekhof 2011-08-09 07:57:54 UTC
A related patch has been committed upstream: https://github.com/beekhof/matahari/commit/e878490

Comment 4 Dave Johnson 2011-09-09 21:27:49 UTC
good 2 go in v0.4.2-2

Comment 5 Russell Bryant 2011-11-16 21:26:28 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description needed

Comment 6 errata-xmlrpc 2011-12-06 11:39:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.