Bug 727978 - returning wrong exit code from subscription-manager redeem
Summary: returning wrong exit code from subscription-manager redeem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-03 20:23 UTC by John Sefler
Modified: 2011-12-06 17:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-08-03 20:23:44 UTC
Description of problem:
With help from cduryee@redhat.com, I am putting together some automated tests for subscription-manager redeem that will run against an onpremises candlepin server with a testing patch that simulates the code from aedwards to replace the candlepin DefaultSubscriptionServiceAdapter.java.

When all is good, it appears that aedwards' SubscriptionServiceAdapter.java will thrown a new AcceptedRequestException with a message "Your subscription activation is being processed and should be available soon."

This is good because in the subscription-manager-gui, an information dialog will be presented to the user.

On the command line, an exit code of 255 is being returned.  This is bad.  As such, my automated tests believe that there is an error.  We are expecting an exit code of 0 for a successful call to redeem.



Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager redeem --email=jsefler@redhat.com
Your subscription activation is being processed and should be available soon. You will be notified via email once it is available. If you have any questions, additional information can be found here: https://access.redhat.com/kb/docs/DOC-53864.
[root@jsefler-onprem-62server ~]# echo $?
255

^^^ Expected an exit code of 0

Comment 1 Chris Duryee 2011-08-15 18:01:52 UTC
700098a subscription-mgr master 0.96.6+

Comment 4 John Sefler 2011-08-22 15:24:15 UTC
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.6-1.git.8.6e109e4.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager redeem --email=tester@redhat.com
Your subscription activation is being processed and should be available soon. You will be notified via email once it is available. If you have any questions, additional information can be found here: https://access.redhat.com/kb/docs/DOC-53864.
[root@jsefler-onprem-62server ~]# echo $?
0

^^^ VERIFIED The AcceptedRequestException thrown by SubscriptionServiceAdapter.java is results in an exitCode of 0 by subscription-manager.



Also verifying error case when the candlepin server does NOT support subscription redemption and throws a ServiceUnavailableException...
[root@jsefler-onprem-62server ~]# subscription-manager redeem --email=tester@redhat.com
Standalone candlepin does not support redeeming a subscription.
[root@jsefler-onprem-62server ~]# echo $?
255

^^^ VERIFIED The error case results in a 255 exit code by subscription-manager.

Comment 6 errata-xmlrpc 2011-12-06 17:23:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.