Bug 727979 - Imported deb packages are db tagged as rpm instead of deb?
Summary: Imported deb packages are db tagged as rpm instead of deb?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space17
TreeView+ depends on / blocked
 
Reported: 2011-08-03 20:26 UTC by James Shelby
Modified: 2012-03-07 09:54 UTC (History)
2 users (show)

Fixed In Version: spacewalk-backend-1.7.30-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-07 09:54:31 UTC


Attachments (Terms of Use)

Description James Shelby 2011-08-03 20:26:36 UTC
Description of problem:
When importing deb packages using rhnpush the database entry seems to be rpm instead of deb.  The file is created and imported but when running spacewalk-data-fsck it shows:
File path mismatch: /spacewalk/satellite/redhat/1/4de/ant/1.8.1-1/all-deb/4de119a9fe2726958a2bb2e3fecfc2f1/ant-1.8.1-1.all-deb.deb (basename: ant-1.8.1-1.all-deb.rpm vs. ant-1.8.1-1.all-deb.deb)


Package details under the web UI show file Unavailable but the file exists exactly as the .deb

-rwxr-x--- 1 apache apache 1457232 Aug  3 14:21 /spacewalk/satellite/redhat/1/4de/ant/1.8.1-1/all-deb/4de119a9fe2726958a2bb2e3fecfc2f1/ant-1.8.1-1.all-deb.deb


Description: 	Java based build tool like make
A system independent (i.e. not shell based) build tool that uses XML
files as "Makefiles". This package contains the scripts and the core
tasks libraries.
Package Architecture: 	all-deb
Available Architectures: 	all-deb
Available From: 	ubuntu 11.04 x86_64
Vendor: 	Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Signing Key: 	(Unknown)
MD5sum: 	4de119a9fe2726958a2bb2e3fecfc2f1
File System Path: 	redhat/1/4de/ant/1.8.1-1/all-deb/4de119a9fe2726958a2bb2e3fecfc2f1/ant-1.8.1-1.all-deb.deb
Package Size: 	1.39 MB
Download: 	
Missing File: ant-1.8.1-1.all-deb.deb
Source Package: 	
File Unavailable 
Version-Release number of selected component (if applicable):
1.6 nightly


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tomas Lestach 2011-08-04 08:22:35 UTC
Looks like ".rpm" is hardcoded in 

backend/satellite_tools/spacewalk-data-fsck:

    row['basename'] = "%s-%s-%s.%s.rpm" % (
                row['name'], row['version'], row['release'], row['arch'])

Valid backend bug ... reassigning

Comment 2 Jan Pazdziora 2011-12-09 11:10:16 UTC
What rhnpush version did you use to push the package?

Comment 3 James Shelby 2011-12-20 14:32:30 UTC
This was the lastest nightly as of that date of the original ticket 8-3-2011

Comment 4 Michael Mráka 2012-02-24 10:15:57 UTC
Fixed by
commit 428dba788cd67d4e5f97345bda996281929f02ba
    727979 - don't hardcode package suffix

Comment 5 Jan Pazdziora 2012-03-07 09:54:31 UTC
Spacewalk 1.7 has been released:

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes17


Note You need to log in before you can comment on or make changes to this bug.