Bug 7280 - A lot of error messages & ide reset when using cdparanoia
A lot of error messages & ide reset when using cdparanoia
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 06:39 EST by Atanas Kolev
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 20:39:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atanas Kolev 1999-11-24 06:39:18 EST
I am using cdparanoia program in my Red Hat 5.2 system and when upgraded it
to Red Hat 6.1 discovered that when running cdparanoia
1) It fails to recognize audio CD or after starting ripping have frozen
near first sectors (output of cdparanoia attached):
 cdparanoia III release 9.6 (August 17, 1999)
(C) 1999 Monty <monty@xiph.org> and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/


Ripping from sector       0 (track  1 [0:00.00])
          to sector   29566 (track  1 [6:34.16])

outputting to 1.wav

 (== PROGRESS == [>                             | 000282 00 ] == :-0 O ==)

2) kernel throws a lot of error messages (dmesg output attached):

hdb: irq timeout: status=0xd0 { Busy }
hdb: ATAPI reset complete
hdb: irq timeout: status=0x80 { Busy }
hdb: ATAPI reset complete
hdb: irq timeout: status=0x80 { Busy }
end_request: I/O error, dev 03:40 (hdb), sector 0
hda: status timeout: status=0x80 { Busy }
hda: drive not ready for command
ide0: reset: success
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x50
ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Logical block address out of range -- (asc=0x21, ascq=0x00)
  The failed "<NULL>" packet command was:
  "be 04 00 00 01 48 00 00 08 f8 00 00 "
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x50
ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Logical block address out of range -- (asc=0x21, ascq=0x00)
  The failed "<NULL>" packet command was:
  "be 04 00 00 01 48 00 00 08 f8 00 00 "
.......
.......
.......

I thing it is related to new kernel capability to automatically mount ,run
o do anything when CD status changed. The problem is that no documentation
of who, when and how handles it.
Comment 1 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 2 farleighs 2000-06-24 00:58:31 EDT
Hello I also have the same issue - my hardware all worked with 6.0, but
somewhere when I upgraded to vanilla 6.2, I get the same errors, noticeable in
the boot sequence. I thought it was a problem with the lite-on brand cd-rom, and
replaced it wiith an (appears to also be a lite-on(!)) and I get the same
errors. I reduced my system to bare bones (again!); no go. Also, I installed
2.2.14-12 on RH website, same kinds of errors...

Fred Farleigh
farleigh@dis.anl.gov
Comment 3 Alan Cox 2000-08-08 13:23:56 EDT
Does rpm -e --nodeps magicdev help ?
Comment 4 Alan Cox 2002-12-13 20:39:13 EST
No answer in 2 years

Note You need to log in before you can comment on or make changes to this bug.