Bug 728018 - texlive inconsolata font support missing
Summary: texlive inconsolata font support missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-texmf
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 23:41 UTC by Hin-Tak Leung
Modified: 2013-07-02 23:52 UTC (History)
4 users (show)

Fixed In Version: texlive-texmf-2007-40.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-29 00:12:16 UTC


Attachments (Terms of Use)

Description Hin-Tak Leung 2011-08-03 23:41:05 UTC
Description of problem:
texlive support for inconsolata font is missing. Consider that inconsolata font is used in quite a few places by default (gnome 3?).

I noticed this problem because I was trying to build R from SVN, and affected by R's switch to inconsolata for the default font for generating manuals.
-----------------
commit 4c60aa8998af9fe07345dc7b2f8cb82f70052673
Author: ripley <ripley@00db46b3-68df-0310-9c12-caf00c1e9a41>
Date:   Thu Jul 7 06:54:01 2011 +0000

    use inconsolata for PDF package manuals
    
    git-svn-id: https://svn.r-project.org/R/trunk@56302 00db46b3-68df-0310-9c12-caf00c1e9a41
----------------------------

Version-Release number of selected component (if applicable):
texlive-texmf-2007-37.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try building R from svn
2.
3.
  
Actual results:

LaTeX errors when creating PDF version.
This typically indicates Rd problems.
LaTeX errors found:
! LaTeX Error: File `inconsolata.sty' not found.

Expected results:
Building of manuals to completion.

Additional info:

It may be appropriate to re-assign this under the levien-inconsolata-font package (and for that to ship texlive inconsolata.sty support files). Also recommended to CC on the package maintainer of R for fedora.

Comment 1 Hin-Tak Leung 2011-08-03 23:44:32 UTC
BTW, it appears that the older behavior (uses courier new for default monospace font for R documentation) may be selected either at build time or at run time
by setting R_RD4PDF="times,hyper" instead of the new default 'times,inconsolata,hyper'. Nonetheless, since inconsolata is used for gnome gui(?), texlive support for it probably should be included.

Comment 2 Hin-Tak Leung 2011-11-05 00:26:20 UTC
Okay, so here is my hand-brewed inconsolata installation (+ texhash + updmap-sys --enable Map=fi4.map). FYI. pdflatex seems to use the type1 version and xetex the opentype version, so probably orthogonal to the system-wide ttf version:
--------------
/usr/share/texmf/tex/latex/inconsolata/inconsolata.sty
/usr/share/texmf/tex/latex/inconsolata/ot1fi4.fd
/usr/share/texmf/tex/latex/inconsolata/qxfi4.fd
/usr/share/texmf/tex/latex/inconsolata/ts1fi4.fd
/usr/share/texmf/tex/latex/inconsolata/t1fi4.fd
/usr/share/texmf/tex/latex/inconsolata/ei1fi4.fd
/usr/share/texmf/tex/latex/inconsolata/ly1fi4.fd
/usr/share/texmf/fonts/tfm/inconsolata/qx-inconsolata.tfm
/usr/share/texmf/fonts/tfm/inconsolata/ts1-inconsolata.tfm
/usr/share/texmf/fonts/tfm/inconsolata/texnansi-inconsolata.tfm
/usr/share/texmf/fonts/tfm/inconsolata/ec-inconsolata.tfm
/usr/share/texmf/fonts/tfm/inconsolata/ei1-inconsolata.tfm
/usr/share/texmf/fonts/tfm/inconsolata/rm-inconsolata.tfm
/usr/share/texmf/fonts/opentype/inconsolata/Inconsolata.otf
/usr/share/texmf/fonts/map/dvips/inconsolata/fi4.map
/usr/share/texmf/fonts/type1/inconsolata/Inconsolata.pfb
/usr/share/texmf/fonts/sfd/inconsolata/Inconsolata.sfd
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-qxtt.enc
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-ts1.enc
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-ec.enc
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-ot1tt.enc
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-ei1.enc
/usr/share/texmf/fonts/enc/dvips/inconsolata/fi4-texnansi.enc
-----------------------

Comment 3 Fedora Update System 2011-11-07 21:00:21 UTC
texlive-texmf-2007-40.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/texlive-texmf-2007-40.fc16

Comment 4 Fedora Update System 2011-11-07 21:00:32 UTC
texlive-texmf-2007-40.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/texlive-texmf-2007-40.fc15

Comment 5 Fedora Update System 2011-11-10 17:38:00 UTC
Package texlive-texmf-2007-40.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-texmf-2007-40.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15630
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-11-29 00:12:16 UTC
texlive-texmf-2007-40.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-11-29 00:18:05 UTC
texlive-texmf-2007-40.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.