Bug 728038 - Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64
Summary: Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 01:21 UTC by Paul Lambert
Modified: 2011-08-07 14:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 02:06:52 UTC


Attachments (Terms of Use)

Description Paul Lambert 2011-08-04 01:21:48 UTC
Description of problem: vmware failed to recompile vmon module


Version-Release number of selected component (if applicable):
vmware player 3.1.4

kernel.x86_64                            2.6.35.13-92.fc14   @updates-testing/14
kernel.x86_64                            2.6.38.8-35.fc15    @updates
kernel.x86_64                            2.6.40-4.fc15

How reproducible: every time


Steps to Reproduce:
1. launch vmware player
2. vmware advises that it needs to rebuild modules
3. attempts to rebuild but exits with error and refers to log file.
  
Actual results:


Expected results:
vmware player has worked successfully for several Fedora upgrades and kernel updates.

Additional info:

cat  /tmp/vmware-root/setup-10455.log
Aug 03 21:17:42.640: app-140671744960288| Log for VMware Workstation pid=10455 version=7.1.4 build=build-385536 option=Release
Aug 03 21:17:42.640: app-140671744960288| The process is 64-bit.
Aug 03 21:17:42.640: app-140671744960288| Host codepage=UTF-8 encoding=UTF-8
Aug 03 21:17:42.640: app-140671744960288| Logging to /tmp/vmware-root/setup-10455.log
Aug 03 21:17:42.863: app-140671744960288| modconf query interface initialized
Aug 03 21:17:42.864: app-140671744960288| modconf library initialized
Aug 03 21:17:42.965: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:42.999: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.026: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.057: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.089: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.197: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.203: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.207: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.212: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.216: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.298: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.303: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.308: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.312: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.316: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.336: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.364: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.487: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.492: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.496: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.501: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.506: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.525: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.562: app-140671744960288| Your GCC version: 4.6
Aug 03 21:17:43.720: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.725: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.729: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.734: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.738: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.916: app-140671744960288| Trying to find a suitable PBM set for kernel 2.6.40-4.fc15.x86_64.
Aug 03 21:17:43.916: app-140671744960288| Building module vmmon.
Aug 03 21:17:43.917: app-140671744960288| Extracting the sources of the vmmon module.
Aug 03 21:17:43.944: app-140671744960288| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.40-4.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.0
Aug 03 21:17:46.375: app-140671744960288| Failed to compile module vmmon!

Comment 1 Josh Boyer 2011-08-04 02:06:52 UTC
I'm sorry, but Fedora can't fix this.  You should contact VMWare for which PBM (whatever that is) is suitable for a 3.0 kernel (2.6.40 is 3.0 rebranded).  Perhaps they can help you with your issue.

Comment 2 Paul Lambert 2011-08-04 14:55:07 UTC
Is this error related to the devel-kernel package needing updated on my cpu?

DECLARE_MUTEX’ declared ‘static’ but never defined

static DECLARE_MUTEX(registrationMutex);

Comment 3 Rastlinux 2011-08-06 18:33:22 UTC
This is crazy. Does Redhat even do testing with at least one of the major windows emulator packages. both Vmware and Virtual Box will not work under this new kernel. You should really do SOME test since so many enterprise level users utilize redhat over light daily users like the ones you find with Ubuntu. Enterprise or corporate users often use a vmware or like product for corporate required packages.

Comment 4 Paul Lambert 2011-08-07 14:51:55 UTC
There were several deprecated kernel calls removed in the latest FE kernel.  This was planned for some time by the Fedora Project but VMware did not remove these from their products thus the compile issues.

Go to this link below and download the .pdf file, change it to a .tar and overwrite all of the directories in /tmp/vmware/sources.  Then repack the tarballs followed by the compile all vmware commmand.

To download the patch click the "modules" link from this website
http://osicarg.wordpress.com/2011/07/15/here-is-patch-for-vmware-player-3-1-4-build-385536-on-linux-2-6-39-2-amd64-kernel/


cd /tmp/vmware/source

\cp -fRv [your download dir]/vmblock-only .
\cp -fRv [your download dir]/vmci-only .
\cp -fRv [your download dir]/vmmon-only .
\cp -fRv [your download dir]/vmnet-only .
\cp -fRv [your download dir]/vsock-only .

tar cvf /usr/lib/vmware/modules/source/vmmon.tar vmmon-only  
tar cvf /usr/lib/vmware/modules/source/vmblock.tar vmblock-only  
tar cvf /usr/lib/vmware/modules/source/vsock-only.tar vsock-only  
tar cvf /usr/lib/vmware/modules/source/vmci.tar vmci-only 
tar cvf /usr/lib/vmware/modules/source/vmnet.tar vmnet-only 

vmware-modconfig --console --install-all


Note You need to log in before you can comment on or make changes to this bug.