Bug 72805 - gdm fails on two issues
gdm fails on two issues
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 18:41 EDT by Paul Wouters
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 18:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2002-08-27 18:41:59 EDT
Description of Problem:
X failed to start through gdm for my user account

Version-Release number of selected component (if applicable):
a 7.0 -> 7.1 -> 7.2beta -> 7.3 ->7.3 beta -> 7.3 -> limbo -> null system,
with some intermixed RedCarpet rpms

Additional Information:

It turned out that there were two problems.
1) i had a .xinitrc starting "panel" as last entry, and this binary no longer
exists, and is replaced by gnome-panel (perhaps a symlink to solve this?)
2) in /etc/X11/prefdm I had an error saying: 

file not found line 1 DESKPRO

Indeed, in /etc/sysconfig/desktop I had a single line saying:

DESKTO

(yes, without P). Checking the scripts, it's likely that these days, it is
expected to contain:

DISPLAYMANAGER=GNOME

I have a desktop.old and desktop.back file containing "GNOME"

btw. I dislike these 'silly playful' new icons with a vengance. I want my
old icons back :(
Comment 1 Havoc Pennington 2002-08-27 18:57:28 EDT
I'm not sure what gdm can do here; you have a broken system config file
(/etc/sysconfig/desktop) and a broken user config file (.xinitrc). You just have
to fix them...

I don't know how /etc/sysconfig/desktop was broken, but as we don't support
upgrades to/from betas, and we don't support systems with Red Carpet packages, 
I think it's fair to say it's due to some random bogon in the history of this
system and not something that's happening to people in general.

Note You need to log in before you can comment on or make changes to this bug.