Bug 728053 - Client will hang when using SASL authentication for TLS sockets
Summary: Client will hang when using SASL authentication for TLS sockets
Keywords:
Status: CLOSED DUPLICATE of bug 726568
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 02:53 UTC by Gunannan Ren
Modified: 2014-06-18 07:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 03:35:07 UTC


Attachments (Terms of Use)

Description Gunannan Ren 2011-08-04 02:53:03 UTC
Description of problem:
When to make use of any SASL authentication for TLS sockets by
setting auth_tls = "sasl" in libvirtd.conf on server side,The
client will hang.

Version-Release number of selected component (if applicable):

libvirt-client-0.9.4-1.el6.x86_64
libvirt-0.9.4-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.set listen_tcp = 1, auth_tls = "sasl" in libvirtd.conf on server side
2.uncomment LIBVIRTD_ARGS="--listen" in /etc/sysconfig/libvirtd on server side
3.setup tls authentication between client and server
4.virsh -c qemu://{hostname of server}/system 
  
Actual results:
the client will hang up

Expected results:

enter the interactive mode, show the "virsh #" prompt

Additional info:

Comment 1 Gunannan Ren 2011-08-04 02:56:51 UTC
I proposed a patch on upstream, it'd better to fix it in RHEL version too.
https://www.redhat.com/archives/libvir-list/2011-August/msg00164.html

Comment 3 Gunannan Ren 2011-08-04 03:35:07 UTC

*** This bug has been marked as a duplicate of bug 726568 ***


Note You need to log in before you can comment on or make changes to this bug.