Bug 72812 - Segfaults on Fullscreen
Segfaults on Fullscreen
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-27 22:45 EDT by Mark Cooke
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 00:38:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-08-27 22:45:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
It seemed to work fine for weeks, I decided to change the fonts used and now it
intermitently segfaults on full screen.
This can be anything, from opening a new tab, to just editing file.

I have changed several different fonts and still the same, currently the
settings I have are:

Allow bold text
Cursor blinks
Show menubar
Run command as lgin shell
Update utmp/wtmp when command launched


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Full screen
2.Editing files

	

Additional info:

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...[New Thread 1024 (LWP 15653)]
0x420a0a89 in wait4 () from /lib/i686/libc.so.6
#0  0x420a0a89 in wait4 () from /lib/i686/libc.so.6
#1  0x4211921c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40855b13 in waitpid () from /lib/i686/libpthread.so.0
#3  0x4019f035 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0

Thread 1 (Thread 1024 (LWP 15653)):
#0  0x420a0a89 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4211921c in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x40855b13 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x4019f035 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#0  0x420a0a89 in wait4 () from /lib/i686/libc.so.6
Comment 1 Havoc Pennington 2002-08-27 23:08:14 EDT
have you also upgraded any font libraries? (fontconfig, xft2, etc.)?
Comment 2 Mark Cooke 2002-08-28 04:03:20 EDT
None what so ever, the install is a fresh install of 'null', only updated via
rawhide.
I have installed about 230 fonts into $HOME/.fonts and also I have a
libfreetype.so.6.2.0 library file in ~/crossover/lib for codeweavers crossover
to work, but that is the only file, that was manually copied there from their
website and as far as I know only available for crossover, and thats only when
it starts.

I will remove and see what happens.
Comment 3 Mark Cooke 2002-08-28 04:10:15 EDT
I have removed all but 1 fonts from .fonts and also removed the
libfreetype.so.6.2.0 from the crossover directory and I still get the segfault.
But this time I can reproduce it (every time) even on a normal terminal size (ie
the size it starts up at), If I open up 5 tabs in a row it segfaults every time
(regardless of size).


Comment 4 Need Real Name 2002-08-31 15:26:54 EDT
I am having possibly similar problems with the gnome terminal.  I changed the
font and then was playing with resizing horizontally, and had two different
types of crashes.  One type of crash locks the pointer in the resize cursor, and
metacity ignores me (metacity is still running, though the terminal doesn't
appear in ps auxwww) but the keyboard still works for ctrl-alt-f2 (but hitting
ctrl-c doesn't kill X for some reason).  The other type of crash simply causes
the terminal to disappear.

I've had the most success at causing problems when doing

1) startx
2) open gnome terminal from icon (added to panel)
3) resize horizontally several times.  always seems to crash eventually.

For the first type of crash, the vt from which I ran startx fills up with this
message:

(metacity:21937): GdkPixbuf-CRITICAL **: file gdk-pixbuf-util.c: line 130
(gdk_pixbuf_copy_area): assertion `dest_pixbuf != NULL' failed

For the second type of crash, I get this:

** (gnome-terminal:21869): CRITICAL **: file pango-context.c: line 310
(pango_context_get_language): assertion `context != NULL' failed

sometimes followed by this:

** (gnome-terminal:21869): CRITICAL **: file pango-context.c: line 310
(pango_context_get_language): assertion `context != NULL' failed
The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadIDChoice (invalid resource ID chosen for this connection)'.
  (Details: serial 6694 error_code 14 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

-Paul Komarek
Comment 5 Owen Taylor 2002-08-31 15:41:37 EDT
The last backtrace is a libXrender bug that was tracked down
yesterday. We should have a fix for that soon. I dont' know
if it is related to the other crashes reported in this bug.
Comment 6 Havoc Pennington 2003-01-08 00:38:42 EST
I think it's safe to assume this is the many-dups resize bug fixed in vte, or
one of a couple rarer vte crash bugs also fixed since 8.0.

In any case, without a backtrace with symbols, not a lot to be done.

Note You need to log in before you can comment on or make changes to this bug.