Bug 728137 - anaconda don't support "ignoredisk --only-use" don't support multipath devices or path like "/dev/disk/by-id/dm-uuid-mpath-20090ef1270000000"
Summary: anaconda don't support "ignoredisk --only-use" don't support multipath device...
Keywords:
Status: CLOSED DUPLICATE of bug 696876
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 07:47 UTC by Gris Ge
Modified: 2011-08-04 14:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 14:08:38 UTC


Attachments (Terms of Use)

Description Gris Ge 2011-08-04 07:47:52 UTC
Description of problem:

Anaconda don't support these following options for multipath devices:
===
ignoredisk --only-use=/dev/disk/by-id/dm-uuid-mpath-20090ef1270000000
===
ignoredisk --only-use=/dev/mapper/mpatha
===
ignoredisk --only-use=mapper/mpatha
===


Version-Release number of selected component (if applicable):
RHEL 6.1 GA.

How reproducible:
100%

Steps to Reproduce:
1. Add above options in kickstart file,
1. For beaker system, add these into job.xml
=============
            <ks_appends>
                <ks_append><![CDATA[
%end
ignoredisk --only-use=mpatha
]]></ks_append>
            </ks_appends>
=============
3. Check wether OS installed correctly.
  
Actual results:
anaconda cannot find the multipath.

Expected results:
Anaconda should support multipath in "ignoredisk --only-use" options.

Additional info:

Comment 1 Gris Ge 2011-08-04 08:03:45 UTC
I also tried "ignoredisk --only-use=mpatha", same issue.

"ignoredisk --only-use=sda" works well on other server via beaker job.xml.

Comment 2 Ales Kozumplik 2011-08-04 14:08:38 UTC
Closing this as dup. The need to target multipath devices in various ways emerged and has been dealt with in bug 677263 and bug 696876.

*** This bug has been marked as a duplicate of bug 696876 ***


Note You need to log in before you can comment on or make changes to this bug.