Bug 728157 - lvrename verb: failed to recognize --force option
Summary: lvrename verb: failed to recognize --force option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 08:47 UTC by Max Benenson
Modified: 2011-12-06 16:59 UTC (History)
9 users (show)

Fixed In Version: lvm2-2.02.86-1.el6
Doc Type: Bug Fix
Doc Text:
Unsupported option --force has been removed from lvrename manpage.
Clone Of:
Environment:
Last Closed: 2011-12-06 16:59:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1522 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2011-12-06 00:50:10 UTC

Description Max Benenson 2011-08-04 08:47:14 UTC
Steps to Reproduce:
1. lvrename --force lv_old_name lv_new_name
  
Actual results:
lvrename: unrecognized option '--force'
  Error during parsing of command line.

Expected results:
--force option should be recognized by lvrename command (or remove this option if not planning to support it)

Additional info:
Red Hat Enterprise Linux Server release 6.1 (Santiago)
lvm2-2.02.83-3.el6.x86_64
lvm2-libs-2.02.83-3.el6.x86_64
kernel-2.6.32-131.2.1.el6.x86_64

Comment 2 Zdenek Kabelac 2011-08-04 11:17:06 UTC
Option --force has been removed from lvrename man page:

https://www.redhat.com/archives/lvm-devel/2011-August/msg00011.html


Also missing new line in help text for lvrename has been fixed:

https://www.redhat.com/archives/lvm-devel/2011-August/msg00010.html

Comment 3 Zdenek Kabelac 2011-08-04 11:17:07 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Unsupported option --force has been removed from lvrename manpage.

Comment 4 Corey Marthaler 2011-08-04 15:32:20 UTC
Adding QA ack for 6.2.

Based on comment #0, a definitive reproducer for this defect exists.

Comment 6 Corey Marthaler 2011-09-08 18:40:24 UTC
Verified that the --force option is no longer in the lvrename man page.

2.6.32-193.el6.x86_64
lvm2-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
lvm2-libs-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
lvm2-cluster-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011

Comment 7 errata-xmlrpc 2011-12-06 16:59:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1522.html


Note You need to log in before you can comment on or make changes to this bug.