Bug 728166 - GUI confused when DumpLocation = /selinux
Summary: GUI confused when DumpLocation = /selinux
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreport
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 09:09 UTC by Michal Nowak
Modified: 2015-02-01 22:54 UTC (History)
10 users (show)

Fixed In Version: libreport-2.0.5-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 12:19:00 UTC


Attachments (Terms of Use)
Ghost problems in GUI (22.34 KB, image/png)
2011-08-04 09:09 UTC, Michal Nowak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1598 normal SHIPPED_LIVE abrt and libreport bug fix and enhancement update 2011-12-06 00:51:16 UTC

Description Michal Nowak 2011-08-04 09:09:19 UTC
Created attachment 516663 [details]
Ghost problems in GUI

Description of problem:

Made an experiment with DumpLocation being set to some nonsense. Such as

  DumpLocation = /selinux

`report-cli -l -f' looks OK, prints just the real crashes. However the GUI has also some empty lines as seen in the picture.

Version-Release number of selected component (if applicable):

abrt-2.0.4-2.el6.x86_64
libreport-2.0.5-3.el6.x86_64

I'd prefer to display only those two (real) problems in the GUI.

Comment 2 Nikola Pajkovsky 2011-08-08 14:17:52 UTC
could you paste here abrt-cli list /selinux?

Comment 3 Michal Nowak 2011-08-08 14:56:48 UTC
[newman@dhcp-25-35 ~]$ abrt-cli list /selinux
Directory:      /selinux/policy_capabilities

Directory:      /selinux/class

Directory:      /selinux/initial_contexts

Directory:      /selinux/avc

Directory:      /selinux/booleans

Comment 4 Denys Vlasenko 2011-08-10 09:44:47 UTC
(In reply to comment #3)
> [newman@dhcp-25-35 ~]$ abrt-cli list /selinux
> Directory:      /selinux/policy_capabilities
> 
> Directory:      /selinux/class
> 
> Directory:      /selinux/initial_contexts
> 
> Directory:      /selinux/avc
> 
> Directory:      /selinux/booleans

Can you attach the strace log of this? We do have some code which should have prevented this, I wonder why it doesn't work for you. (I can't reproduce your result, for me this cmd shows nothing).

Comment 5 Nikola Pajkovsky 2011-08-10 13:24:54 UTC
commit ff5718265cb3f583cbd16152800a9cf6d75090f2
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Wed Aug 10 13:48:41 2011 +0200

    dd_opendir: require "time" file to exist even in read-only opens
    
    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>

Comment 6 Michal Nowak 2011-08-10 14:39:56 UTC
(In reply to comment #4)
> Can you attach the strace log of this? We do have some code which should have
> prevented this, I wonder why it doesn't work for you. (I can't reproduce your
> result, for me this cmd shows nothing).

Seems we don't need is due to comment #5.

Comment 8 Jiri Moskovcak 2011-08-12 11:30:16 UTC
It's actually caused by a bug in libreport -> reassigning

Comment 11 errata-xmlrpc 2011-12-06 12:19:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1598.html


Note You need to log in before you can comment on or make changes to this bug.