Bug 72821 - up2date slow when downloading big packages
Summary: up2date slow when downloading big packages
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-28 07:13 UTC by Pavel
Modified: 2015-01-07 23:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 14:23:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel 2002-08-28 07:13:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020826

Description of problem:
I'm sure it's dup of 53134, but I can't reopen that bug.

I'm using up2date 2.9.55-1 from rawhide and I have the same problem downloading
kernel source package. It seems that up2date uses lot of CPU and memory. When it
downloads ~90% of the file (~24 Mb) whole system becomes irresponsible - I can't
even use ctrl-alt-del on the console to reboot. My system has 64 Mb of memory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run up2date to update kernel-source package.
2.
3.
	

Actual Results:  Very high CPU and memory usage. System becomes irresponsible

Expected Results:  Download and package.

Additional info:

Comment 1 Michael Young 2002-08-28 10:49:33 UTC
The symptoms don't sound the same as bug 53134, where the download got slower
and slower as the system swapped more and more, I don't recall the system ever
grinding to a halt.

Comment 2 Pavel 2002-08-28 11:00:04 UTC
Yes they are. When I wrote that I'm sure it's a dupe, I meant that I do see
those symptoms. Download starts at about 40 Kb/sec and, at ~75%, it drops to 8
Kb/sec and less. I also see a lot of swapping, even though swap usage is
relatively low (about 30% according to gnome system monitor applet). I have 188
Mb swap (and 64 Mb memory). Also memory usage graph looks as a zigzag  - 70% -
100% - 70% every few seconds.

Comment 3 Adrian Likins 2002-08-28 22:15:23 UTC
behaviour may be similar to 53134, but I wouldnt consider it
a dup (if for no other reason than that pretty much all the
network based code has changed fairly drastically since then...)

Investigating now..

Comment 4 Adrian Likins 2002-09-01 03:24:11 UTC
Looks to have been an issue with rhnlib

should be fixed in rhnlib-0.9-1

Comment 5 Matt Jamison 2003-05-20 14:23:03 UTC
confirmed to be working correctly.

closing bug.


Note You need to log in before you can comment on or make changes to this bug.