Bug 728266 - Unsubscribe from subscription manager GUI is broken.
Summary: Unsubscribe from subscription manager GUI is broken.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-04 14:35 UTC by Michael Stead
Modified: 2011-12-06 17:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC
Red Hat Product Errata RHBA-2011:1696 normal SHIPPED_LIVE python-rhsm bug fix update 2011-12-06 00:49:52 UTC

Description Michael Stead 2011-08-04 14:35:08 UTC
Description of problem:
Unsubscribe from subscription manager GUI is broken.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.5-1.git.1.a2d60c6.el6.x86_64
subscription-manager-firstboot-0.96.5-1.git.1.a2d60c6.el6.x86_64
subscription-manager-0.96.5-1.git.1.a2d60c6.el6.x86_64
subscription-manager-debuginfo-0.96.5-1.git.1.a2d60c6.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Subscribe to a product (I used All Available tab)
2. Select subscription in My Subscriptions tab and click Unsubscribe.
  
Actual results:
Error dialog is presented stating "There was an error unsubsribing from..."

Expected results:
Unsubscribe should complete successfully and the subscription should be removed. 

Additional info:

Comment 2 John Sefler 2011-08-04 15:32:42 UTC
Note: This recent regression appears isolated to the GUI.  The unsubscribe from the CLI still works.

Comment 6 Chris Duryee 2011-08-08 19:26:52 UTC
a04e5ffdd26b582fd5169b0bc705c42cc834149b python-rhsm master 0.96.9+

Comment 7 Shwetha Kallesh 2011-08-09 05:57:31 UTC
Moving the bug to verified as the Unsubscribe completes successfully and subscription is removed.

RPM's used :

subscription-manager-firstboot-0.96.5-1.git.16.531d88e.el6.x86_64
subscription-manager-gnome-0.96.5-1.git.16.531d88e.el6.x86_64
subscription-manager-0.96.5-1.git.16.531d88e.el6.x86_64

Comment 8 errata-xmlrpc 2011-12-06 17:23:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.