Bug 728267 - When non-posix groups are skipped, initgroups returns random GID
When non-posix groups are skipped, initgroups returns random GID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.1
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
Chandrasekar Kannan
:
Depends On:
Blocks: 725868 748857 748865
  Show dependency treegraph
 
Reported: 2011-08-04 10:38 EDT by Stephen Gallagher
Modified: 2015-01-04 18:50 EST (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.5.1-46.el6
Doc Type: Bug Fix
Doc Text:
Cause: When processing group memberships for a user who is a member of a group lacking POSIX attributes, loop index was incremented even for groups that should be skipped Consequence: Instead of being skipped, non-POSIX groups were returned with a random GID Fix: The loop index was only incremented for valid POSIX groups Result: non-POSIX groups are skipped and correct group membership is returned
Story Points: ---
Clone Of:
: 748865 (view as bug list)
Environment:
Last Closed: 2011-12-06 11:39:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FedoraHosted SSSD 928 None None None Never

  None (edit)
Description Stephen Gallagher 2011-08-04 10:38:54 EDT
Description of problem:
A bug in indexing of GIDs when a groups is skipped causes random data to be returned during initgroups.

When a group is skipped, we must not increment the buffer index.
Comment 5 Kaushik Banerjee 2011-09-27 04:05:53 EDT
Verified in version:

# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.5.1                             Vendor: Red Hat, Inc.
Release     : 52.el6                        Build Date: Tue 20 Sep 2011 09:11:03 PM IST
Install Date: Mon 26 Sep 2011 05:56:30 PM IST      Build Host: x86-010.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.5.1-52.el6.src.rpm
Size        : 3550647                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 6 Jakub Hrozek 2011-10-27 11:10:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: When processing group memberships for a user who is a member of a group lacking POSIX attributes, loop index was incremented even for groups that should be skipped
Consequence: Instead of being skipped, non-POSIX groups were returned with a random GID
Fix: The loop index was only incremented for valid POSIX groups
Result: non-POSIX groups are skipped and correct group membership is returned
Comment 7 errata-xmlrpc 2011-12-06 11:39:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1529.html

Note You need to log in before you can comment on or make changes to this bug.