Bug 728271 - Yum depsolve issues with dbus and dbus-libs [NEEDINFO]
Summary: Yum depsolve issues with dbus and dbus-libs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus
Version: 5.8
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 14:42 UTC by Todd Ellis
Modified: 2014-06-02 13:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:04:21 UTC
pm-rhel: needinfo? (ellistd)


Attachments (Terms of Use)

Description Todd Ellis 2011-08-04 14:42:40 UTC
Description of problem:

One of my 10 client systems has been having issues with the command "yum upgrade" with numerous depsolve errors.  I got around most of these by downgrading and then upgrading each package, but I have not been successful at this approach to fixing the issue with dbus and dbus-libs.

The number of unresolved dependencies on this one system is alarming.  Have I done something that's broken this system?

Version-Release number of selected component (if applicable):

dbus-1.1.3-14.el5.x86_64.rpm
dbus-libs-1.1.2-12.el5.x86_64.rpm

How reproducible:

I executed the following commands:
yum clean all
yum reinstall dbus dbus-libs

I have also tried yum downgrade dbus and get depsolve errors.  I have not done yum erase dbus because it asks to remove over 200 packages and I do not feel comfortable agreeing to that unless I'm sure that will fix the problem without creating new ones.

I have also tried yum upgrade (this was how I found the issue in the first place), and yum upgrade --skip-broken, which still doesn't work around the problem.  package-cleanup --problems lists a number of items as well.  I am attaching that in additional info.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Loaded plugins: rhnplugin, security
Setting up Reinstall Process
Resolving Dependencies
--> Running transaction check
---> Package dbus.x86_64 0:1.1.2-12.el5 set to be updated
---> Package dbus-libs.i386 0:1.1.2-12.el5 set to be erased
---> Package dbus-libs.i386 0:1.1.2-12.el5 set to be updated
---> Package dbus-libs.x86_64 0:1.1.2-12.el5 set to be updated
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be updated
--> Processing Dependency: dbus = 1.1.2-14.el5 for package: dbus-libs
--> Running transaction check
---> Package dbus.x86_64 0:1.1.2-14.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch        Version             Repository                 Size
================================================================================
Removing:
 dbus-libs      i386        1.1.2-12.el5        installed                 246 k
Reinstalling:
 dbus           x86_64      1.1.2-12.el5        rhel-x86_64-client-5      233 k
 dbus-libs      i386        1.1.2-12.el5        rhel-x86_64-client-5      124 k
 dbus-libs      x86_64      1.1.2-12.el5        rhel-x86_64-client-5      123 k
 dbus-libs      i386        1.1.2-14.el5        rhel-x86_64-client-5      123 k
Updating for dependencies:
 dbus           x86_64      1.1.2-14.el5        rhel-x86_64-client-5      233 k

Transaction Summary
================================================================================
Install       0 Package(s)
Upgrade       1 Package(s)
Remove        1 Package(s)
Reinstall     4 Package(s)
Downgrade     0 Package(s)

Total download size: 837 k
Is this ok [y/N]: y
Downloading Packages:
(1/5): dbus-libs-1.1.2-12.el5.x86_64.rpm                 | 123 kB     00:00     
(2/5): dbus-libs-1.1.2-14.el5.i386.rpm                   | 123 kB     00:00     
(3/5): dbus-libs-1.1.2-12.el5.i386.rpm                   | 124 kB     00:00     
(4/5): dbus-1.1.2-14.el5.x86_64.rpm                      | 233 kB     00:00     
(5/5): dbus-1.1.2-12.el5.x86_64.rpm                      | 233 kB     00:00     
--------------------------------------------------------------------------------
Total                                            46 kB/s | 837 kB     00:18     
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
dbus is needed by dbus-libs-1.1.2-12.el5.x86_64
dbus is needed by (installed) dbus-libs-1.1.2-12.el5.x86_64
dbus is needed by (installed) dbus-x11-1.1.2-12.el5.x86_64
dbus is needed by (installed) dbus-devel-1.1.2-12.el5.i386
dbus is needed by (installed) dbus-devel-1.1.2-12.el5.x86_64
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Expected results:


Additional info:
package-cleanup --problems

Reading local RPM database
Processing all local requires
Missing dependencies:
Package libuser-devel requires libuser = 0.54.7-2.el5.5
Package sqlite-devel requires sqlite = 3.3.6-2
Package expat-devel requires expat = 1.95.8-8.2.1
Package newt-devel requires newt = 0.52.2-12.el5
Package gcc-gfortran requires gcc = 4.1.2-44.el5
Package gcc-gfortran requires libgfortran = 4.1.2-44.el5
Package xulrunner-devel requires xulrunner = 1.9.0.5-1.el5_2
Package libuser-devel requires libuser = 0.54.7-2.el5.5
Package curl-devel requires curl = 7.15.5-2.el5
Package krb5-devel requires krb5-libs = 1.6.1-31.el5
Package curl-devel requires curl = 7.15.5-2.el5
Package dbus-libs requires dbus = 1.1.2-14.el5
Package cyrus-sasl-devel requires cyrus-sasl-lib = 2.1.22-4
Package krb5-devel requires krb5-libs = 1.6.1-31.el5
Package libsepol-devel requires libsepol = 1.15.2-1.el5
Package gcc-c++ requires gcc = 4.1.2-44.el5
Package gcc-c++ requires libstdc++ = 4.1.2-44.el5
Package cyrus-sasl-devel requires cyrus-sasl-lib = 2.1.22-4
Package pam-devel requires pam = 0.99.6.2-4.el5
Package newt-devel requires newt = 0.52.2-12.el5
Package xulrunner-devel requires xulrunner = 1.9.0.5-1.el5_2
Package libselinux-devel requires libselinux = 1.33.4-5.1.el5
Package ruby-devel requires ruby-libs = 1.8.5-5.el5_2.6
Package libstdc++-devel requires libstdc++ = 4.1.2-44.el5
Package ruby-devel requires ruby-libs = 1.8.5-5.el5_2.6
Package nss-devel requires nss = 3.12.2.0-2.el5
Package db4-devel requires db4 = 4.3.29-9.fc6
Package nspr-devel requires nspr = 4.7.3-2.el5
Package e2fsprogs-devel requires e2fsprogs-libs = 1.39-20.el5
Package libselinux-devel requires libselinux = 1.33.4-5.1.el5
Package expat-devel requires expat = 1.95.8-8.2.1
Package glib2-devel requires glib2 = 2.12.3-2.fc6
Package openssl-devel requires openssl = 0.9.8e-7.el5
Package rpm-build requires popt = 1.10.2.3-9.el5
Package rpm-build requires rpm = 4.4.2.3-9.el5
Package rpm-build requires rpm-libs = 4.4.2.3-9.el5
Package rpm-devel requires popt = 1.10.2.3-9.el5
Package rpm-devel requires rpm = 4.4.2.3-9.el5
Package rpm-devel requires rpm-libs = 4.4.2.3-9.el5
Package libgcrypt-devel requires libgcrypt = 1.2.4-1.el5
Package db4-devel requires db4 = 4.3.29-9.fc6
Package openssl-devel requires openssl = 0.9.8e-7.el5
Package rpm-devel requires popt = 1.10.2.3-9.el5
Package rpm-devel requires rpm = 4.4.2.3-9.el5
Package rpm-devel requires rpm-libs = 4.4.2.3-9.el5
Package pam-devel requires pam = 0.99.6.2-4.el5

rpm -Va --nofiles --nodigest
Unsatisfied dependencies for glib2-devel-2.12.3-2.fc6.x86_64: glib2 = 2.12.3-2.fc6
Unsatisfied dependencies for nspr-devel-4.7.3-2.el5.x86_64: nspr = 4.7.3-2.el5
Unsatisfied dependencies for db4-devel-4.3.29-9.fc6.x86_64: db4 = 4.3.29-9.fc6
Unsatisfied dependencies for krb5-devel-1.6.1-31.el5.i386: krb5-libs = 1.6.1-31.el5
Unsatisfied dependencies for ruby-devel-1.8.5-5.el5_2.6.x86_64: ruby-libs = 1.8.5-5.el5_2.6
Unsatisfied dependencies for expat-devel-1.95.8-8.2.1.i386: expat = 1.95.8-8.2.1
Unsatisfied dependencies for libselinux-devel-1.33.4-5.1.el5.i386: libselinux = 1.33.4-5.1.el5
Unsatisfied dependencies for openssl-devel-0.9.8e-7.el5.x86_64: openssl = 0.9.8e-7.el5
Unsatisfied dependencies for pam-devel-0.99.6.2-4.el5.i386: pam = 0.99.6.2-4.el5
Unsatisfied dependencies for libgcrypt-devel-1.2.4-1.el5.x86_64: libgcrypt = 1.2.4-1.el5
Unsatisfied dependencies for rpm-build-4.4.2.3-9.el5.x86_64: popt = 1.10.2.3-9.el5, rpm = 4.4.2.3-9.el5, rpm-libs = 4.4.2.3-9.el5
Unsatisfied dependencies for expat-devel-1.95.8-8.2.1.x86_64: expat = 1.95.8-8.2.1
Unsatisfied dependencies for curl-devel-7.15.5-2.el5.x86_64: curl = 7.15.5-2.el5
Unsatisfied dependencies for sqlite-devel-3.3.6-2.x86_64: sqlite = 3.3.6-2
Unsatisfied dependencies for libstdc++-devel-4.1.2-44.el5.x86_64: libstdc++ = 4.1.2-44.el5
Unsatisfied dependencies for gcc-gfortran-4.1.2-44.el5.x86_64: gcc = 4.1.2-44.el5, libgfortran = 4.1.2-44.el5
Unsatisfied dependencies for xulrunner-devel-1.9.0.5-1.el5_2.i386: xulrunner = 1.9.0.5-1.el5_2
Unsatisfied dependencies for gcc-c++-4.1.2-44.el5.x86_64: gcc = 4.1.2-44.el5, libstdc++ = 4.1.2-44.el5
Unsatisfied dependencies for nss-devel-3.12.2.0-2.el5.x86_64: nss = 3.12.2.0-2.el5
Unsatisfied dependencies for newt-devel-0.52.2-12.el5.i386: newt = 0.52.2-12.el5
Unsatisfied dependencies for ruby-devel-1.8.5-5.el5_2.6.i386: ruby-libs = 1.8.5-5.el5_2.6
Unsatisfied dependencies for db4-devel-4.3.29-9.fc6.i386: db4 = 4.3.29-9.fc6
Unsatisfied dependencies for cyrus-sasl-devel-2.1.22-4.i386: cyrus-sasl-lib = 2.1.22-4
Unsatisfied dependencies for dbus-libs-1.1.2-14.el5.i386: dbus = 1.1.2-14.el5
Unsatisfied dependencies for libuser-devel-0.54.7-2.el5.5.x86_64: libuser = 0.54.7-2.el5.5
Unsatisfied dependencies for openssl-devel-0.9.8e-7.el5.i386: openssl = 0.9.8e-7.el5
Unsatisfied dependencies for e2fsprogs-devel-1.39-20.el5.x86_64: e2fsprogs-libs = 1.39-20.el5
Unsatisfied dependencies for pam-devel-0.99.6.2-4.el5.x86_64: pam = 0.99.6.2-4.el5
Unsatisfied dependencies for rpm-devel-4.4.2.3-9.el5.i386: popt = 1.10.2.3-9.el5, rpm = 4.4.2.3-9.el5, rpm-libs = 4.4.2.3-9.el5
Unsatisfied dependencies for krb5-devel-1.6.1-31.el5.x86_64: krb5-libs = 1.6.1-31.el5
Unsatisfied dependencies for cyrus-sasl-devel-2.1.22-4.x86_64: cyrus-sasl-lib = 2.1.22-4
Unsatisfied dependencies for xulrunner-devel-1.9.0.5-1.el5_2.x86_64: xulrunner = 1.9.0.5-1.el5_2
Unsatisfied dependencies for curl-devel-7.15.5-2.el5.i386: curl = 7.15.5-2.el5
Unsatisfied dependencies for libselinux-devel-1.33.4-5.1.el5.x86_64: libselinux = 1.33.4-5.1.el5
Unsatisfied dependencies for rpm-devel-4.4.2.3-9.el5.x86_64: popt = 1.10.2.3-9.el5, rpm = 4.4.2.3-9.el5, rpm-libs = 4.4.2.3-9.el5
Unsatisfied dependencies for newt-devel-0.52.2-12.el5.x86_64: newt = 0.52.2-12.el5
Unsatisfied dependencies for libsepol-devel-1.15.2-1.el5.x86_64: libsepol = 1.15.2-1.el5
Unsatisfied dependencies for libuser-devel-0.54.7-2.el5.5.i386: libuser = 0.54.7-2.el5.5

Comment 1 RHEL Product and Program Management 2014-03-07 12:41:11 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-02 13:04:21 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.