Bug 728282 - Review Request: perl-Bot-BasicBot - Simple irc bot baseclass
Summary: Review Request: perl-Bot-BasicBot - Simple irc bot baseclass
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 15:14 UTC by Petr Šabata
Modified: 2011-08-05 13:39 UTC (History)
2 users (show)

Fixed In Version: perl-Bot-BasicBot-0.87-1.fcf17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-05 13:39:51 UTC
mmaslano: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Petr Šabata 2011-08-04 15:14:25 UTC
Spec URL: http://psabata.fedorapeople.org/pkgs/perl-Bot-BasicBot/perl-Bot-BasicBot.spec
SRPM URL: http://psabata.fedorapeople.org/pkgs/perl-Bot-BasicBot/perl-Bot-BasicBot-0.87-1.fc15.src.rpm
Description:
Basic bot system designed to make it easy to do simple bots, optionally
forking longer processes (like searches) concurrently in the background.

Comment 1 Marcela Mašláňová 2011-08-05 11:37:29 UTC
- rpmlint OK
- package must be named according to Guidelines OK
- spec file name must match the base package %{name} OK
- package must meet the Packaging Guidelines OK
- package must be licensed with Fedora approved license OK
- license field must match actual license OK
- text of the license in its own file must be included in %doc OK
- sources must match the upstream source OK
- package MUST successfully compile and build OK
- architecture listed in ExcludeArch MUST have a bug filed in bugzilla OK
- build dependencies must be listed in BuildRequires OK
- handle locales properly with %find_lang macro OK
- shared library files must call ldconfig in %post(un) OK
- packages must NOT bundle system libraries OK
- package must own all directories that it creates OK
- permissions on files must be set properly OK
- package must consistently use macros OK
- package must contain code, or permissable content OK
- large documentation must go in a -doc OK
- %doc must not affect the runtime of the application OK
- header files must be in a -devel package OK
- static libraries must be in a -static package OK
- library files that end in .so (without suffix) must go in a -devel OK
- devel package usually require base package OK
- packages must NOT contain any .la libtool archives OK
- GUI applications must include a %{name}.desktop file OK
- packages must not own files or directories already owned by other packages OK

http://koji.fedoraproject.org/koji/taskinfo?taskID=3254045

rpm -qp --provides ~/Downloads/perl-Bot-BasicBot-0.87-1.fc17.noarch.rpm 
perl(Bot::BasicBot) = 0.87
perl-Bot-BasicBot = 0.87-1.fc17
rpm -qp --requires ~/Downloads/perl-Bot-BasicBot-0.87-1.fc17.noarch.rpm 
perl(:MODULE_COMPAT_5.14.1)  
perl(Carp)  
perl(Encode)  
perl(Exporter)  
perl(IRC::Utils)  
perl(POE::Component::IRC) >= 6.62
perl(POE::Component::IRC::Plugin::Connector)  
perl(POE::Component::IRC::State)  
perl(POE::Filter::Line)  
perl(POE::Kernel)  
perl(POE::Session)  
perl(POE::Wheel::Run)  
perl(Text::Wrap)  
perl(base)  
perl(strict)  
perl(warnings)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

APPROVED

Comment 2 Petr Šabata 2011-08-05 11:43:06 UTC
New Package SCM Request
=======================
Package Name: perl-Bot-BasicBot
Short Description: Simple IRC bot baseclass
Owners: psabata mmaslano ppisar
Branches: 
InitialCC: perl-sig

Comment 3 Gwyn Ciesla 2011-08-05 13:20:40 UTC
Git done (by process-git-requests).

Comment 4 Petr Šabata 2011-08-05 13:39:51 UTC
Thank you both.


Note You need to log in before you can comment on or make changes to this bug.