Bug 728286 - Review Request: perl-Module-Extract-VERSION - Extract a module version without running code
Review Request: perl-Module-Extract-VERSION - Extract a module version withou...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: perl-Test-Version
  Show dependency treegraph
 
Reported: 2011-08-04 11:23 EDT by Paul Howarth
Modified: 2011-09-07 06:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Module-Extract-VERSION-1.01-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 06:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
iarnell: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2011-08-04 11:23:40 EDT
Spec URL:
http://subversion.city-fan.org/repos/cfo-repo/perl-Module-Extract-VERSION/branches/fedora/perl-Module-Extract-VERSION.spec
SRPM URL:
http://www.city-fan.org/~paul/extras/perl-Module-Extract-VERSION/perl-Module-Extract-VERSION-1.01-2.fc17.src.rpm

Description:
This module lets you pull out of module source code the version number for the
module. It assumes that there is only one $VERSION in the file.
Comment 1 Iain Arnell 2011-08-11 23:59:14 EDT
Koji (success) http://koji.fedoraproject.org/koji/taskinfo?taskID=3267269
Comment 2 Iain Arnell 2011-08-12 00:04:32 EDT
You need to filter perl(ExtUtils::MakeMaker::_version) from the automatically detected provides.

koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=3267269

Spec looks sane, clean and consistent; license is correct (GPL+ or Artistic);
make test passes cleanly.

Source tarballs match upstream (sha1sum):
752e28122e92edbb0db452f6cce2af62775b589e Module-Extract-VERSION-1.01.tar.gz
752e28122e92edbb0db452f6cce2af62775b589e Module-Extract-VERSION-1.01.tar.gz.srpm

Final provides / requires are sane:

======> perl-Module-Extract-VERSION-1.01-2.fc17.noarch.rpm <======
====> rpmlint
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
====> provides
perl(ExtUtils::MakeMaker::_version)  
perl(Module::Extract::VERSION) = 1.01
perl-Module-Extract-VERSION = 1.01-2.fc17
====> requires
perl(Carp)  
perl(:MODULE_COMPAT_5.14.1)  
perl(strict)  
perl(subs)  
perl(vars)  
perl(warnings)  
====> obsoletes
====> conflicts

======> perl-Module-Extract-VERSION-1.01-2.fc17.src.rpm <======
====> rpmlint
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
====> provides
====> requires
perl(ExtUtils::MakeMaker)  
perl(Test::More)  
perl(Test::Pod) >= 1.00
perl(Test::Pod::Coverage) >= 1.00
perl(Test::Prereq)  
====> obsoletes
====> conflicts


====> mock install
INFO: mock.py version 1.1.12 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
Mock Version: 1.1.12
INFO: Mock Version: 1.1.12
State Changed: lock buildroot
INFO: installing package(s): perl-Module-Extract-VERSION-1.01-2.fc17.noarch.rpm
INFO: Ignored option -c (probably due to merging -yc != -y -c)

================================================================================
 Package
       Arch   Version     Repository                                       Size
================================================================================
Installing:
 perl-Module-Extract-VERSION
       noarch 1.01-2.fc17 /perl-Module-Extract-VERSION-1.01-2.fc17.noarch 6.5 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total size: 6.5 k
Installed size: 6.5 k

Installed:
  perl-Module-Extract-VERSION.noarch 0:1.01-2.fc17                              


State Changed: unlock buildroot
State Changed: end
Comment 3 Paul Howarth 2011-08-12 04:42:23 EDT
(In reply to comment #2)
> You need to filter perl(ExtUtils::MakeMaker::_version) from the automatically
> detected provides.

Whoops. Fixed in -3:

Spec URL:
http://subversion.city-fan.org/repos/cfo-repo/perl-Module-Extract-VERSION/branches/fedora/perl-Module-Extract-VERSION.spec

SRPM URL:
http://www.city-fan.org/~paul/extras/perl-Module-Extract-VERSION/perl-Module-Extract-VERSION-1.01-3.fc17.src.rpm
Comment 4 Iain Arnell 2011-08-12 04:48:44 EDT
Confirmed. Filtering works with both old and new rpm. The rest of the review stands. APPROVED.
Comment 5 Paul Howarth 2011-08-12 05:04:18 EDT
New Package SCM Request
=======================
Package Name: perl-Module-Extract-VERSION
Short Description: Extract a module version without running code
Owners: pghmcfc
Branches: EL-4 EL-5 EL-6 F-14 F-15 F-16
InitialCC: perl-sig

Thanks for the review Iain.
Comment 6 Gwyn Ciesla 2011-08-12 08:38:15 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2011-08-12 10:26:30 EDT
perl-Module-Extract-VERSION-1.01-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.el5
Comment 8 Fedora Update System 2011-08-12 10:26:38 EDT
perl-Module-Extract-VERSION-1.01-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.fc15
Comment 9 Fedora Update System 2011-08-12 10:26:46 EDT
perl-Module-Extract-VERSION-1.01-3.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.el4
Comment 10 Fedora Update System 2011-08-12 10:26:54 EDT
perl-Module-Extract-VERSION-1.01-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.fc16
Comment 11 Fedora Update System 2011-08-12 10:27:02 EDT
perl-Module-Extract-VERSION-1.01-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.el6
Comment 12 Fedora Update System 2011-08-12 10:27:09 EDT
perl-Module-Extract-VERSION-1.01-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-Module-Extract-VERSION-1.01-3.fc14
Comment 13 Fedora Update System 2011-08-23 00:26:02 EDT
perl-Module-Extract-VERSION-1.01-3.fc14 has been pushed to the Fedora 14 stable repository.
Comment 14 Fedora Update System 2011-08-23 00:34:25 EDT
perl-Module-Extract-VERSION-1.01-3.fc15 has been pushed to the Fedora 15 stable repository.
Comment 15 Fedora Update System 2011-08-23 16:21:52 EDT
perl-Module-Extract-VERSION-1.01-3.fc16 has been pushed to the Fedora 16 stable repository.
Comment 16 Fedora Update System 2011-08-30 17:02:39 EDT
perl-Module-Extract-VERSION-1.01-3.el4 has been pushed to the Fedora EPEL 4 stable repository.
Comment 17 Fedora Update System 2011-08-30 17:03:50 EDT
perl-Module-Extract-VERSION-1.01-3.el5 has been pushed to the Fedora EPEL 5 stable repository.
Comment 18 Fedora Update System 2011-08-30 17:04:10 EDT
perl-Module-Extract-VERSION-1.01-3.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.