Bug 728307 - SELinux is preventing /sbin/rpc.statd from 'write' accesses on the sock_file rpcbind.sock.
Summary: SELinux is preventing /sbin/rpc.statd from 'write' accesses on the sock_file ...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d8c6aa544305134fbc4e4970e4f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 16:29 UTC by Frank Murphy
Modified: 2011-09-21 18:43 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 18:43:59 UTC


Attachments (Terms of Use)

Description Frank Murphy 2011-08-04 16:29:19 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-3.fc16.x86_64
reason:         SELinux is preventing /sbin/rpc.statd from 'write' accesses on the sock_file rpcbind.sock.
time:           Thu Aug  4 17:27:21 2011

description:
:SELinux is preventing /sbin/rpc.statd from 'write' accesses on the sock_file rpcbind.sock.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpc.statd should be allowed write access on the rpcbind.sock sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpc.statd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rpcd_t:s0
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                rpcbind.sock [ sock_file ]
:Source                        rpc.statd
:Source Path                   /sbin/rpc.statd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nfs-utils-1.2.4-3.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-10.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.0-0.rc7.git10.1.fc16.x86_64 #1 SMP Fri Jul 22
:                              01:50:34 UTC 2011 x86_64 x86_64
:Alert Count                   205
:First Seen                    Sun 10 Jul 2011 10:54:05 IST
:Last Seen                     Sat 30 Jul 2011 09:21:03 IST
:Local ID                      ce9adec0-edc8-4c63-a7b8-d2cf997a09ee
:
:Raw Audit Messages
:type=AVC msg=audit(1312014063.633:16): avc:  denied  { write } for  pid=1204 comm="rpc.statd" name="rpcbind.sock" dev=tmpfs ino=16515 scontext=system_u:system_r:rpcd_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1312014063.633:16): arch=x86_64 syscall=connect success=no exit=EACCES a0=c a1=7fffbc1d22d0 a2=17 a3=8 items=0 ppid=1202 pid=1204 auid=4294967295 uid=29 gid=29 euid=29 suid=29 fsuid=29 egid=29 sgid=29 fsgid=29 tty=(none) ses=4294967295 comm=rpc.statd exe=/sbin/rpc.statd subj=system_u:system_r:rpcd_t:s0 key=(null)
:
:Hash: rpc.statd,rpcd_t,var_run_t,sock_file,write
:
:audit2allow
:
:#============= rpcd_t ==============
:allow rpcd_t var_run_t:sock_file write;
:
:audit2allow -R
:
:#============= rpcd_t ==============
:allow rpcd_t var_run_t:sock_file write;
:

Comment 1 Daniel Walsh 2011-08-04 17:26:48 UTC
I believe systemd created this sock file, but does not seem to have created it with the correct label.

Comment 2 Lennart Poettering 2011-08-21 12:29:26 UTC
rpcbind does not use socket activation, so systemd is not involved.

Comment 3 Daniel Walsh 2011-08-22 16:26:16 UTC
Yes it does.

rpm -q rpcbind -l | grep socket
/lib/systemd/system/rpcbind.socket

Comment 4 Miroslav Grepl 2011-08-25 10:57:37 UTC
*** Bug 733127 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2011-09-20 15:37:28 UTC
I believe this is fixed in systemd-35-1.fc16

Comment 6 Lennart Poettering 2011-09-21 18:43:59 UTC
OK, closing then, please reopen when this continues to exist.


Note You need to log in before you can comment on or make changes to this bug.