Bug 728359 - Usage not viewable without authenticating
Summary: Usage not viewable without authenticating
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-04 20:14 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:51:43 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-08-04 20:14:03 UTC
Description of problem:

[root@katello-ci katello]# katello system register --help
error: Missing credentials and unable to authenticate using Kerberos (more in the log file)


[root@katello-ci katello]# katello -u admin -p admin system register --help
Usage: katello [options]

Options:
  -h, --help            show this help message and exit
  -g                    grep friendly output
  -v                    verbose, more structured output
  -d DELIMITER          grep friendly output column delimiter
  --name=NAME           system name (required)
  --org=ORG             organization name (required)
  --environment=ENVIRONMENT
                        environment name eg: development



Version-Release number of selected component (if applicable):
katello-cli-0.1.4-1.git.23.d7e76b7.fc14.noarch

How reproducible:


Steps to Reproduce:
1. Try to get usage without specifying user/pw
2. 
3.
  
Actual results:
Fails with missing creds error

Expected results:
Usage text

Additional info:

Comment 1 Ivan Necas 2011-08-15 09:53:42 UTC
Fixed in branch a-keys, not merged yet to master - waiting for UI code reviews.

Will inform when it propagates to master.

Comment 2 Ivan Necas 2011-08-17 06:47:00 UTC
Fix was merged into the master branch.

Comment 3 Corey Welton 2011-09-22 15:17:31 UTC
QA Verified

Comment 6 Mike McCune 2013-08-16 18:10:07 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.