Bug 728368 - abrt doesn't record segfault
Summary: abrt doesn't record segfault
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 20:28 UTC by Thomas Meyer
Modified: 2015-02-01 22:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-10 13:49:19 UTC


Attachments (Terms of Use)

Description Thomas Meyer 2011-08-04 20:28:33 UTC
Description of problem:

a segfault in rhythmbox occurs, but nothing is displayed in the abrt-gui.

I'm using kernel 3.0 and can see this lines in the kernel log:

[259077.292215] show_signal_msg: 289 callbacks suppressed
[259077.292222] rhythmbox[7811]: segfault at c ip 4c72c8e4 sp a4133dbc error 4 in librhythmbox-core.so.4.0.0[4c678000+126000]
[259077.334879] rhythmbox-metad[7800]: segfault at 5 ip 0804f999 sp bfd4eec0 error 4 in rhythmbox-metadata[8048000+17000]
[259469.169018] rhythmbox[7968]: segfault at c ip 4c72c8e4 sp a0967dbc error 4 in librhythmbox-core.so.4.0.0[4c678000+126000]

Version-Release number of selected component (if applicable):
abrt.i686                                          2.0.3-1.fc15                     @updates
abrt-addon-ccpp.i686                               2.0.3-1.fc15                     @updates
abrt-addon-kerneloops.i686                         2.0.3-1.fc15                     @updates
abrt-addon-python.i686                             2.0.3-1.fc15                     @updates
abrt-cli.i686                                      2.0.3-1.fc15                     @updates
abrt-desktop.i686                                  2.0.3-1.fc15                     @updates
abrt-devel.i686                                    2.0.3-1.fc15                     @updates
abrt-gui.i686                                      2.0.3-1.fc15                     @updates
abrt-libs.i686                                     2.0.3-1.fc15                     @updates
abrt-plugin-bugzilla.i686                          2.0.3-1.fc15                     @updates
abrt-plugin-logger.i686                            2.0.3-1.fc15                     @updates
abrt-plugin-mailx.i686                             2.0.3-1.fc15                     @updates
abrt-plugin-reportuploader.i686                    2.0.3-1.fc15                     @updates
abrt-plugin-rhtsupport.i686                        2.0.3-1.fc15                     @updates

$ pgrep abrt -l
768 abrtd
1555 abrt-applet
7853 abrt-gui

Comment 1 Jiri Moskovcak 2011-08-05 08:16:14 UTC
can you please try:

cat /proc/sys/kernel/core_pattern

should like like this:

|/usr/libexec/abrt-hook-ccpp /var/spool/abrt %s %c %p %u %g %t %h %e 636f726500

if not, then abrt-ccpp has not been started - this is caused by a bug in spec file, which doesn't add this service if updating from abrt1 to abrt2, to fix this, please run:


chkconfig --add abrt-ccpp
chkconfig --add abrt-oops

this ^ will make the service start after reboot

service abrt-ccpp start
service abrt-oops start

this ^ will start it immediately

Comment 2 Thomas Meyer 2011-08-05 13:37:31 UTC
Yes! Thanks for the hint. seems to work now:

$ cat /proc/sys/kernel/core_pattern
|/usr/libexec/abrt-hook-ccpp /var/spool/abrt %s %c %p %u %g %t %h %e 636f726500

But ran directly into this bug: #722747 - But I guess this is already worked on.


Note You need to log in before you can comment on or make changes to this bug.