Bug 728438 - Text highlighting creates glitches in Spyder
Summary: Text highlighting creates glitches in Spyder
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: spyder
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Novacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 07:33 UTC by Kamil Páral
Modified: 2018-04-11 08:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-01 13:24:46 UTC


Attachments (Terms of Use)
screencast of the issue (513.32 KB, application/ogg)
2011-08-05 07:47 UTC, Matěj Cepl
no flags Details

Description Kamil Páral 2011-08-05 07:33:25 UTC
Description of problem:
Please see bug report at:
http://code.google.com/p/spyderlib/issues/detail?id=713

When using intel driver, I see graphical artifacts when highlighting text in Spyder (until Spyder redraws the area due to integrated word highlighter several seconds later). I don't see this issue when using vesa driver.

See video:
http://spyderlib.googlecode.com/issues/attachment?aid=7130000000&name=bug.ogv&token=381d8366fa2e2fd3a811f75757eaca3d

My graphics card is:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 20e4
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 48
	Region 0: Memory at f4400000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0300c  Data: 41b9
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: i915
	Kernel modules: i915

I have seen the same issue on a different hardware with (I suppose different) intel video card, but I don't have its lspci now.

An important fact is that everything worked when I booted Fedora 15 from Live CD. Something must have got broken since then.

I don't really know whether this is a intel driver issue, or some QT issue. I hope you can guide me.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.15.0-5.fc15.x86_64
spyder-2.0.12-1.fc15.noarch
qt3-3.3.8b-35.fc15.x86_64
qt-4.7.3-6.fc15.x86_64
qt-x11-4.7.3-6.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run Spyder
2. highlight words by double clicking on dragging the cursor (see the video)
  
Actual results:
graphical glitches only on intel driver

Expected results:
no graphical glitches

Comment 1 Matěj Cepl 2011-08-05 07:47:48 UTC
Created attachment 516840 [details]
screencast of the issue

Comment 2 Matěj Cepl 2011-08-05 07:49:34 UTC
Looking at the video, I would tend to believe that the investigation should start from the top, and that means probably the text editor component used by Spyder. Reassigning in the appropriate direction.

Comment 3 Rex Dieter 2011-08-10 20:48:07 UTC
can reproduce on my f15 box with old i945.
my f14 box with i965 seems ok.

sounds like a fun one to debug what's going wrong.

don't see anything similar, in other PyQt4-using projects either (like eric or marave).

I'm tempted to bounce this back to spyder for now, there is some latent display/render glitch/bug.

Comment 4 Kamil Páral 2012-03-01 12:52:57 UTC
This is fixed in F16 and most recent spyder version. Close if appropriate.

Comment 5 Radek Novacek 2012-03-01 13:24:46 UTC
Thanks for retesting it. Closing the bug as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.