Bug 728478 - Updating fresh installed F15 breaks keyboard backlight
Summary: Updating fresh installed F15 breaks keyboard backlight
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 752275 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 10:08 UTC by Nikolai Maziashvili
Modified: 2012-03-06 19:29 UTC (History)
8 users (show)

Fixed In Version: kernel-3.2.9-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 19:29:32 UTC


Attachments (Terms of Use)

Description Nikolai Maziashvili 2011-08-05 10:08:59 UTC
Description of problem:
Ufter updating freshly installed F15 keyboard backlight stoped working.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install F15 
2. Update
3.
  
Actual results:


Expected results:
Keyboard backlight working

Additional info:
I really have no ide what info you will need. Please tell me what to provide you with.

Comment 1 Nikolai Maziashvili 2011-08-12 19:52:09 UTC
When i saw this bug get assigned to kernel team i booted laptop with previous kernel to see if it was actually kernel related. Well, you probably new that, but i wanted to see it myself. 
And indeed i booted into kernel 2.6.38.6-26.rc1.fc15.x86_64, one that got updated by 2.6.40-4.fc15.x86_64 and keyboard backlight worked (as it used to).
Hopefully next kernel update will fix this issue.

Comment 2 Nikolai Maziashvili 2011-08-29 10:43:08 UTC
Did a test run of F16 alpha with kernel 3.0 and problem is not resolved. I will try to look closely to find out exactly when keyboard loosing backlight. During the initial boot it works. At the point when it about to mount my partitions light goes off for good.

Comment 3 Nikolai Maziashvili 2011-10-25 07:53:50 UTC
Adding configuration file sony-laptop.conf in /etc/modprobe.d/ with one single line:
options sony-laptop kbd_backlight=1

Solves this issue. I guess it was missing configuration item and not a problem in kernel.
I don't know if this is a intended solution, i really want to know what went wrong since F15 fresh installation, when backlight worked out of the box to latest F15 updates when it stopped working. 
Im using F16 at this moment and out of the box backlight was not working either.
Please give me some technical explanation, it's really bothering me.

Comment 4 Josh Boyer 2011-11-02 18:14:20 UTC
(In reply to comment #3)
> Adding configuration file sony-laptop.conf in /etc/modprobe.d/ with one single
> line:
> options sony-laptop kbd_backlight=1
> 
> Solves this issue. I guess it was missing configuration item and not a problem
> in kernel.
> I don't know if this is a intended solution, i really want to know what went
> wrong since F15 fresh installation, when backlight worked out of the box to
> latest F15 updates when it stopped working. 
> Im using F16 at this moment and out of the box backlight was not working
> either.
> Please give me some technical explanation, it's really bothering me.

When the keyboard backlight support was originally added, the commit said to default it to on with a 10 second timeout.  That actually wasn't the case, as the default value is commented out for the kbd_backlight parameter.  Because it is a static variable, it gets set to 0 by default without some other form of initialization.

However, it seems the function to set the value wasn't actually called immediately, so whatever state the keyboard was in initially would remain.  Then commit df410d522410e67660 was introduced during the 2.6.39 timeframe to immediately set whatever value was present (as well as attempt to restore/reset the state on module removal or resume).  That seems to have now forced the light off immediately when the module is loaded.

Comment 5 Josh Boyer 2011-11-02 18:38:04 UTC
https://lkml.org/lkml/2011/11/2/274

Comment 6 Josh Boyer 2011-11-09 18:22:14 UTC
*** Bug 752275 has been marked as a duplicate of this bug. ***

Comment 7 Nikolai Maziashvili 2011-11-10 20:35:28 UTC
Josh thank you for your explanation.

Comment 8 Josh Boyer 2012-02-28 20:32:04 UTC
This fell through the cracks upstream, but I resent it.  I've gone ahead and committed the patch to Fedora.

Comment 9 Fedora Update System 2012-02-29 01:34:25 UTC
kernel-3.2.8-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.8-3.fc16

Comment 10 Fedora Update System 2012-03-01 09:29:28 UTC
Package kernel-3.2.8-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.8-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2745/kernel-3.2.8-3.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2012-03-01 22:52:42 UTC
kernel-3.2.9-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.9-1.fc16

Comment 12 Fedora Update System 2012-03-06 19:29:32 UTC
kernel-3.2.9-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.