Bug 72849 - RFE: package search / filter option
Summary: RFE: package search / filter option
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-28 12:08 UTC by Mike MacCana
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 12:08:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2002-08-28 12:08:48 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
The new Packages tool is brilliant.  
 
I think a search / filter option would be useful to add to 
redhat-config-packages. Imagine a search / filter along the lines of the 
following: 
 
Search in [ category ^] for ____________________ 
( ) installed packages ( ) available packages ( ) both 
 
Categories would include name, name and description, vendor, and other useful 
fields from spec files. The result is a cut down list of packages, not sorted 
into their comps groups but rather just a flat list. 
 
 
Eg, you'd like to install tex and you're not sure of the packages name:  
  
Search in name for tex 
( ) installed packages (*) available packages ( ) both 
 
If you were running low on hard disk space and wanted to remove some of your 
non critical apps: 
 
Search in desciption for game 
(*) installed packages ( ) available packages ( ) both 
 
If you wanted to know quickly what packages from a particular vendor were 
installed: 
 
Search in vendor for oracle 
(*) installed packages ( ) available packages ( ) both 
 
I think this would be extremely useful for both new and experienced users 
alike. I realize Red Hat staff are extremely busy right now chasing real bugs, 
but I think it would benefit users to mark the bug as DEFERRED if this feature 
is worth implementing.  
 
Thanks, 
 
Mike 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
This is not a bug, just a suggestion.	 
 
Additional info:

Comment 1 Jeremy Katz 2002-08-28 20:52:30 UTC
Definitely a reasonable idea, probably in combination with the more traditional
"all the packages we ship" view.  Not for this release, though.

Comment 2 Mattias Dahlberg 2002-10-13 10:39:58 UTC
Reopen now when 8.0 has been released?



Note You need to log in before you can comment on or make changes to this bug.