Bug 728520 - Lost Focus on text with Fullpage Background Image
Lost Focus on text with Fullpage Background Image
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-05 08:17 EDT by Sebastian
Modified: 2013-01-04 14:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-29 06:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Example file with wrong behavior (17.47 KB, application/vnd.oasis.opendocument.text-template)
2011-08-05 10:22 EDT, Sebastian
no flags Details

  None (edit)
Description Sebastian 2011-08-05 08:17:19 EDT
Description of problem:
We use a background image in a letter template to put a watermark and the company logo in place. The image is set to be far in the background, spans the whole page, and text should run on top of it.
The Text, which one day should be the content of the letter, cannot get focus once you (even accidentally) clicked on the image. This is quite unhelpful if one actually wants to write a letter.

Version-Release number of selected component (if applicable):
libreoffice-writer-3.3.2.2-10.fc15.x86_64
openoffice.org-writer-3.3.0-20.6.fc14.x86_64

How reproducible:
Every time, see below:

Steps to Reproduce:
1. Put an image in the background, let it span the page and configure it to have text on top.
2. Write some text and click on the image. Try to get back to the text then.
  
Actual results:
No focus on text.

Expected results:
Focus on text.
Comment 1 Caolan McNamara 2011-08-05 08:41:56 EDT
attach an example. Lower the barrier to reproduce.
Comment 2 Sebastian 2011-08-05 10:22:44 EDT
Created attachment 516902 [details]
Example file with wrong behavior

Thanks for your time, of course a file would have made sense from the first minute on.

This is a censored file (the image, of course, was just drawn quickly…).
Comment 3 Sebastian 2011-08-26 09:06:05 EDT
ping?
Comment 4 Caolan McNamara 2011-08-26 11:28:07 EDT
press escape ?
Comment 5 Caolan McNamara 2011-08-26 12:18:51 EDT
Cedric fixed this "hard to select the right thing" with prioritising foreground content over background when looking for something to select http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4b74188c87cdeb881aacbc053594a7c697ab1ca

Could backport that, though its still a little experimental.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89aaee9adad9d0ceac5a6a422b415152abe74e8c related, but that was only done today.
Comment 6 Caolan McNamara 2011-08-29 06:58:32 EDT
Yeah, too fresh IMO to backport safely. Its an old problem, with a new solution for 3.5
Comment 7 Robert Scheck 2011-08-29 08:42:41 EDT
What does that mean now? Will I have to wait till LibreOffice 3.5 for getting 
this fix? If so, when can I expect that version roughly?
Comment 8 Caolan McNamara 2011-08-31 05:04:12 EDT
yes, 3.5. I'm too cowardly to backport the in-progress fix for this long-standing problem to the stable 3-4 version in F15/F16

http://wiki.documentfoundation.org/ReleasePlan#3.5_release is the 3.5 release schedule
Comment 9 Sebastian 2011-08-31 05:30:10 EDT
Escape does not work, unfortunately.

But it seems there is a solution, although February 2012 is extremly far away considering that any user of the document has to apply extreme caution till then as not to click on the image by accident. This would not by any chance fit into 3.4.4?

Thank you for the time spent investigating this!
Comment 10 Robert Scheck 2012-12-25 18:50:16 EST
Referencing this issue with case #00769507 in the Red Hat Network for RHEL 6, 
because I am suffering this issue on my RHEL 6 workstation now, while Fedora 
Rawhide (LibreOffice 3.6.x) seems to work like a charm regarding this...
Comment 11 Michael Stahl 2013-01-04 14:00:48 EST
just for the record, there was quite a series of iterative fixes and new regressions for this problem area upstream (see for example fdo bugs 52182 and 58142); currently in 3.6.5 and 4.0 there are no known problems any more.
Comment 12 Robert Scheck 2013-01-04 14:15:56 EST
Michael, can you please ensure that your colleagues working on my RHN case are 
really aware about that also? I don't know if these patches are backportable, 
alternatively I'm still a fan of rebasing LibreOffice in RHEL 6. Thank you...

Note You need to log in before you can comment on or make changes to this bug.