Bug 728531 - [abrt] kernel: BUG: Bad page state in process systemd-readahe pfn:37ac5: TAINTED -----B
Summary: [abrt] kernel: BUG: Bad page state in process systemd-readahe pfn:37ac5: TAI...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:355164e2e25b7ff6f36073c6445...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 12:39 UTC by Mads Kiilerich
Modified: 2012-07-10 21:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-10 21:40:39 UTC


Attachments (Terms of Use)
dmesg (122.15 KB, text/plain)
2011-08-05 12:43 UTC, Mads Kiilerich
no flags Details
dmesg with 3.2.10-1.fc16.i686.debug (144.97 KB, text/plain)
2012-03-16 20:37 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2011-08-05 12:39:51 UTC
abrt version: 2.0.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.0.0-4.1.fc16.i686.PAE root=/dev/mapper/VolGroup-LogVol01 ro
comment:        Happens on boot of Mac mini booting from 32 bit EFI to 32 bit kernel
kernel:         undefined
kernel_tainted: 32
kernel_tainted_long: System has hit bad_page.
reason:         BUG: Bad page state in process systemd-readahe  pfn:37ac5
time:           Fri Aug  5 14:37:12 2011

backtrace:
:BUG: Bad page state in process systemd-readahe  pfn:37ac5
:page:f62c18a0 count:0 mapcount:0 mapping:  (null) index:0x0
:page flags: 0x80400000(uncached)
:Modules linked in: firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video
:Pid: 410, comm: systemd-readahe Tainted: G    B       3.0.0-4.1.fc16.i686.PAE #1
:Call Trace:
: [<c04cc1af>] bad_page+0xcf/0xe6
: [<c04ccd88>] get_page_from_freelist+0x2e0/0x3c7
: [<c04cd10a>] __alloc_pages_nodemask+0x165/0x672
: [<c047381f>] ? lock_release+0x15a/0x17b
: [<c0473905>] ? lock_acquire+0xc5/0xe4
: [<c04ceba0>] ? file_ra_state_init+0x24/0x24
: [<c04ceca8>] __do_page_cache_readahead+0xb0/0x18b
: [<c0505f7f>] ? file_free_rcu+0x4f/0x4f
: [<c04cef3d>] force_page_cache_readahead+0x63/0x80
: [<c04ca544>] sys_fadvise64_64+0x18c/0x20a
: [<c0853d1f>] sysenter_do_call+0x12/0x38

smolt_data:
:
:
:General
:=================================
:UUID: d924d11f-0440-40ee-9c9c-69c1469d96c3
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3667.00
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1833
:System Memory: 974
:System Swap: 1023
:Vendor: Apple Inc.
:System: Macmini2,1 1.0
:Form factor: Low Profile Desktop
:Kernel: 3.0.0-4.1.fc16.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4545:22545:4545:22545) pci, firewire_ohci, FIREWIRE, FW322/323
:(32902:10169:32902:29296) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(5772:28:4203:134) pci, ath5k, ETHERNET, AR5001 Wireless Network Adapter
:(32902:10146:32902:29296) pci, i915, VIDEO, Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
:(32902:10150:32902:29296) pci, None, VIDEO, Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
:(32902:10192:0:0) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:0:0) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(4523:17250:4523:21281) pci, sky2, ETHERNET, Marvell RDK-8053
:(32902:10200:33668:30336) pci, HDA Intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10207:32902:29296) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(32902:10181:32902:29296) pci, ahci, STORAGE, 82801GBM/GHM (ICH7 Family) SATA AHCI Controller
:(32902:10202:32902:29296) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10147:0:0) pci, None, NONE, N/A
:(32902:10185:32902:29296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:32902:29296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10144:32902:29296) pci, agpgart-intel, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
:(32902:10186:32902:29296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:32902:29296) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:32902:29296) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-LogVol01 / ext4 4096 4096 2451286 1360232 1335339 622592 505702 505702
:/dev/sda3 /boot ext4 1024 1024 495844 398576 372976 128016 127763 127763
:/dev/sda1 WITHHELD vfat 512 512 403266 365459 365459 0 0 0
:

Comment 1 Mads Kiilerich 2011-08-05 12:43:09 UTC
Created attachment 516891 [details]
dmesg

There are plenty of other bad page state messages - I guess they have the same root cause

Comment 2 Dave Jones 2012-03-14 16:39:10 UTC
The 3.2.10 update being pushed into updates-testing right now has some extra debug checks enabled in the VM code. If you could run that for a while, and report back anything that looks unusual, that might help.

thanks.

Comment 3 Mads Kiilerich 2012-03-16 20:37:33 UTC
Created attachment 570704 [details]
dmesg with 3.2.10-1.fc16.i686.debug

Comment 4 Dave Jones 2012-03-19 14:18:55 UTC
interesting, thanks.

This machine passes a memtest run ok ?
That it happens so early in boot is very suspicious.

Comment 5 Mads Kiilerich 2012-03-19 15:24:04 UTC
memtest86+ do apparently not support EFI.

"memtester 700" do not show any problems, and the machine do in general work fine both under OS/X and Linux.

Are the other options for memtest?

I guess this mainly is a problem of 32 bit EFI being less supported than 64 bit, perhaps because the older Apple firmware is more broken and grub+kernel doesn't have the necessary workarounds?

Comment 6 Dave Jones 2012-03-19 16:11:23 UTC
it's feasible that the EFI memory map is either broken, or being mis-parsed.

For the 32bit mini's, you're probably better off with bootcamp tbh.

Comment 7 Mads Kiilerich 2012-03-19 16:34:09 UTC
With "bootcamp" you mean the "CSM" bios emulation? That do unfortunately not work for booting from USB and is thus not an option for my use case.

Despite these error messages the systems seem to work OK in EFI, something I wouldn't expect if the memory map really was mis-parsed.

Comment 8 Mads Kiilerich 2012-05-25 14:13:16 UTC
I now see a different kind of BUGs - all with i915 in the call stack. I don't know if that is a coincidence.

[    2.967284] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    2.989704] dracut: Starting plymouth daemon
[    3.133666] usb 5-2: New USB device found, idVendor=05ac, idProduct=8240
[    3.133671] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.133674] usb 5-2: Product: IR Receiver
[    3.133677] usb 5-2: Manufacturer: Apple Computer, Inc.
[    3.142775] generic-usb 0003:05AC:8240.0005: hiddev0,hidraw4: USB HID v1.11 Device [Apple Computer, Inc. IR Receiver] on usb-0000:00:1d.3-2/input0
[    3.703694] BUG: Bad page state in process plymouthd  pfn:37e2a
[    3.703759] page:f5e4a540 count:0 mapcount:0 mapping:  (null) index:0x0
[    3.703812] page flags: 0x80400000(uncached)
[    3.703857] Modules linked in: i915 drm_kms_helper drm i2c_algo_bit i2c_core video
[    3.703869] Pid: 194, comm: plymouthd Not tainted 3.3.7-1.fc16.i686.PAE #1
[    3.703872] Call Trace:
[    3.703884]  [<c10fe6b7>] bad_page+0xa7/0xf0
[    3.703888]  [<c10ff85c>] get_page_from_freelist+0x46c/0x520
[    3.703894]  [<c1214c42>] ? cred_has_capability+0xb2/0x120
[    3.703898]  [<c10ffb7b>] __alloc_pages_nodemask+0x10b/0x740
[    3.703903]  [<c1215117>] ? selinux_vm_enough_memory+0x47/0x60
[    3.703907]  [<c110d37e>] shmem_getpage_gfp+0x23e/0x5f0
[    3.703911]  [<c110d764>] shmem_read_mapping_page_gfp+0x34/0x50
[    3.703934]  [<f8951dcc>] i915_gem_object_bind_to_gtt+0x19c/0x590 [i915]
[    3.703949]  [<f8954fbc>] i915_gem_object_pin+0x12c/0x190 [i915]
[    3.703963]  [<f895508e>] i915_gem_object_pin_to_display_plane+0x6e/0x180 [i915]
[    3.703969]  [<c12692d5>] ? put_dec+0x85/0x90
[    3.703973]  [<c1269dc1>] ? string+0x31/0xb0
[    3.703989]  [<f89644a9>] intel_pin_and_fence_fb_obj+0x59/0x100 [i915]
[    3.703994]  [<c126aa7d>] ? vsnprintf+0x9d/0x370
[    3.704008]  [<f8964bb1>] intel_pipe_set_base+0x81/0x270 [i915]
[    3.704074]  [<f880fc55>] ? drm_get_connector_name+0x45/0x50 [drm]
[    3.704082]  [<f874e93d>] drm_crtc_helper_set_config+0x63d/0xa20 [drm_kms_helper]
[    3.704095]  [<f8812235>] drm_mode_setcrtc+0xe5/0x410 [drm]
[    3.704105]  [<f8804e18>] drm_ioctl+0x378/0x480 [drm]
[    3.704115]  [<f8812150>] ? drm_mode_setplane+0x3b0/0x3b0 [drm]
[    3.704125]  [<f8804aa0>] ? drm_copy_field+0x80/0x80 [drm]
[    3.704132]  [<c1156542>] do_vfs_ioctl+0x82/0x5a0
[    3.704137]  [<c1217867>] ? selinux_file_ioctl+0x47/0xe0
[    3.704140]  [<c1156acf>] sys_ioctl+0x6f/0x80
[    3.704147]  [<c102e909>] ? smp_apic_timer_interrupt+0x59/0x90
[    3.704156]  [<c155225f>] sysenter_do_call+0x12/0x28
[    3.704159] Disabling lock debugging due to kernel taint

Comment 9 Dave Jones 2012-07-10 21:40:39 UTC
32bit EFI is pretty much unsupported, so it's unlikely this is going to improve any time soon.  You might get lucky reporting it upstream, but honestly I'm not optimistic.


Note You need to log in before you can comment on or make changes to this bug.