Bug 728541 - virt-manager resize to vm broken
Summary: virt-manager resize to vm broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738806
TreeView+ depends on / blocked
 
Reported: 2011-08-05 13:38 UTC by Eric Blake
Modified: 2011-12-06 16:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
: 738806 (view as bug list)
Environment:
Last Closed: 2011-12-06 16:15:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description Eric Blake 2011-08-05 13:38:16 UTC
Description of problem:
After upgrading to the latest virt-manager, resizing to VM appears to mix up the x and y coordinates, resulting in a window that is tall and narrow with scrollbar on the bottom and vertical spacing above and below the vm, instead of short and wide to match the vm size.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start up a VM with vnc graphics and attach to it
2. View -> Resize to VM
3.
  
Actual results:
window has wrong dimensions

Expected results:
window should match VM screen dimensions

Additional info:

Comment 3 Cole Robinson 2011-08-30 19:38:31 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 5 Huming Jiang 2011-09-02 06:23:20 UTC
Reproduced with virt-manager-0.9.0-5.el6.x86_64

Verified with the following components:
kernel-2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
libvirt-0.9.4-7.el6.x86_64
python-virtinst-0.600.0-2.el6.noarch
virt-manager-0.9.0-6.el6.x86_64.


Steps:
1. start up a VM with vnc graphics and attach to it
2. View -> Resize to VM
The guest's window has right dimensions
3. Drag the guest's window to make it larger.
4. View -> Resize to VM
The guest's window has right dimensions

Comment 6 Cole Robinson 2011-11-07 16:41:51 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 7 errata-xmlrpc 2011-12-06 16:15:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.