Bug 728580 - xfprint4-manager doesn't show printers
Summary: xfprint4-manager doesn't show printers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfprint
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 16:48 UTC by Heiko Adams
Modified: 2011-09-13 05:49 UTC (History)
2 users (show)

Fixed In Version: xfprint-4.6.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 05:48:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 5160 None None None Never
Xfce 6089 None None None Never

Description Heiko Adams 2011-08-05 16:48:21 UTC
Description of problem:
xfprint4-manager doesn't show the installed printers. When starting from shell, the following error message is shown:
> ** (xfprint4-manager:10938): WARNING **: xfprint: XfPrint/system is not set

Version-Release number of selected component (if applicable):
xfprint-4.6.0-6.fc15.i686

How reproducible:
allways

Steps to Reproduce:
1. open a terminal
2. start xfprint4-manager
3.
  
Actual results:
no printers are shown

Expected results:
the installed printers should be listed

Additional info:

Comment 1 Kevin Fenzi 2011-08-05 21:13:00 UTC
I suppose I can apply that upstream patch... or we could look at just dropping xfprint. 

It's really not that useful. What are you trying to do with it? 
Does system-config-printer and the native cups tools not work for you?

Comment 2 Heiko Adams 2011-08-05 21:33:37 UTC
I just installed it to have a nearly complete XFCE desktop as a Gnome replacement. System-config and cups tools work fine and as expected.

But I'd recommend to apply the upstream patch because otherwise some users could think fedora is shipping an incomplete xfce. But that's only my 5 cent.

Comment 3 Kevin Fenzi 2011-08-05 21:51:04 UTC
Well, there's good reasons why it's optional in the xfce group and NOT included on the Xfce spin. ;) 

It requires a2ps to print things, and is in general pretty dead upstream. 
In any case I'll look into the patches or just dropping it.

Comment 4 Heiko Adams 2011-08-05 22:18:16 UTC
Well, if it's dead upstream ... kick it like beckham :D

Comment 5 Kevin Fenzi 2011-08-20 20:37:15 UTC
I guess I would be inclined to update f14/f15 with the patch and then drop it in 16+... 

adding Christoph here to get his take on it too. 

Here's a f15 scratch with 4.6.1 + the patch: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=3289235

Comment 6 Christoph Wickert 2011-08-22 23:00:34 UTC
(In reply to comment #5)
> I guess I would be inclined to update f14/f15 with the patch and then drop it
> in 16+... 

+1

Comment 7 Fedora Update System 2011-08-27 20:31:24 UTC
xfprint-4.6.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfprint-4.6.1-1.fc15

Comment 8 Fedora Update System 2011-08-27 20:49:35 UTC
xfprint-4.6.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xfprint-4.6.1-1.fc14

Comment 9 Fedora Update System 2011-08-31 01:41:23 UTC
Package xfprint-4.6.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfprint-4.6.1-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xfprint-4.6.1-1.fc14
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-09-13 05:48:35 UTC
xfprint-4.6.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-09-13 05:49:53 UTC
xfprint-4.6.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.