Bug 728604 - many self checks fail on PPC
many self checks fail on PPC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
16
powerpc Unspecified
high Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Betappc
  Show dependency treegraph
 
Reported: 2011-08-05 14:44 EDT by Karsten Hopp
Modified: 2012-03-14 09:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 12:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2011-08-05 14:44:05 EDT
Description of problem:
p.e. 
1 warning generated.
fatal error: malformed or corrupted PCH file: 'declaration ID out-of-range for AST file'
FileCheck error: '-' is empty.
1 error generated.
....
  Expected Passes    : 2860
  Expected Failures  : 22
  Unexpected Failures: 36


Version-Release number of selected component (if applicable):
llvm-2.9-2.fc16

How reproducible:
alway

Steps to Reproduce:
1. ppc-koji build dist-f16 --scratch llvm-2.9-2.fc16.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=268275


Additional info:
This is currently blocking F16 composes on PPC
Comment 1 Michel Alexandre Salim 2011-08-06 05:18:42 EDT
grep ^FAIL: build.log shows that most of the failures are C++-related; however, some of them are failed C and ObjC test cases too.

Having no PPC machine to test on, I'm not sure which to choose of the two solutions:
- disable clang on PPC
  or
- just disable its test suite

Do the PPC maintainers have a preference? Thanks.
Comment 2 Karsten Hopp 2011-08-06 05:59:16 EDT
We're hoping to get a PPC machine for Fedora packagers exactly for this type of problems later this year. Until then I'd prefer to have the testsuite disabled. Disabling clang might cause lots of dependency errors in other packages.
Comment 3 Michel Alexandre Salim 2011-08-06 06:26:32 EDT
Hm, you're right, flterm and pure have build dependencies on clang (I package the latter, and it probably should be fixed -- I tried switching to clang for building before and it didn't quite work out).

Do you need the test suite disabled on ppc64 as well? From the changelog it looks like you enabled them. I don't see a 'ppc64-koji' launcher so I can't test that build target.
Comment 4 Karsten Hopp 2011-08-06 06:41:51 EDT
ppc-koji starts builds on ppc and ppc64 similar to 'koji' which starts builds on x86 and x86_64.
Please disable the testsuite on ppc and ppc64.
Comment 5 Michel Alexandre Salim 2011-08-06 07:02:19 EDT
Right, I noticed after sending my message that it's doing both builds. Still awaiting scratch build completion; if it's successful I'll commit and close this bug -- I'm assuming the PPC compose will rebuild any updated packages automatically?

It's probably too late to report this to upstream - they don't support older versions at all - but I'll make sure to try the first 3.0 pre-release on PPC as well and report the results before the final release goes out.
Comment 6 Michel Alexandre Salim 2011-08-06 11:11:46 EDT
LLVM tests fail on ppc64 as well, so I'm disabling that too. Scratch build now finishes fine:

  http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=269044

and the changes have been pushed. Setting this to ON_QA; please close when the ppc* compose succeeds.
Comment 7 Dan Horák 2011-09-07 05:41:46 EDT
Wouldn't be it better to always run the test, but only don't fail the build on platforms where failuers are expected like on ppc or s390? E.g. use something like

make check \
%ifarch ppc s390
|| :
%else
%{nil}
%endif


s390(x) seems to have similar problems like ppc/ppc64. llvm-2.9-0.2.rc1.fc16 contains failed tests, but the build was successful, for llvm-2.9-2.fc16 the build fails because the failing tests.
Comment 8 Karsten Hopp 2011-10-27 12:16:08 EDT
llvm-2.9-4.fc16 built fine on ppc*, closing

Note You need to log in before you can comment on or make changes to this bug.