Bug 728608 - rpm-4.9.1 adds a slash to directories
Summary: rpm-4.9.1 adds a slash to directories
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 18:55 UTC by H.J. Lu
Modified: 2011-08-17 10:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 10:25:08 UTC


Attachments (Terms of Use)

Description H.J. Lu 2011-08-05 18:55:28 UTC
build/files.c in rpm-4.9.1 has

    /* Arrange trailing slash on directories */
    if (fl->isDir)
        diskPath = rstrcat(&diskPath, "/");

which leads to a trailing slash on directories in file list
in a rpm.  It is incompatible with rpms built with older
rpm, which require directories without trailing slash on
directories.

Comment 1 Panu Matilainen 2011-08-15 10:45:38 UTC
Yes, 4.9.1 is a broken brown-paperbag release, this has been fixed in 4.9.1.1. Note that 4.9.1 was never pushed as an update for F15 so it's not affected, unless you manually build rpm from dist-git which does currently have 4.9.1 (it was intended to go as an update to f15 but will obviously be skipped and 4.9.1.1 should land there soonish).

Comment 2 H.J. Lu 2011-08-16 13:20:17 UTC
I built rpm from git repository, which still has the broken 4.9.1.

Comment 3 Panu Matilainen 2011-08-17 10:25:08 UTC
rpm-4.9.1.1 is in dist-git now, closing this as F15 was only affected at the git repository level. And actual update is also being built right now but that's another story.


Note You need to log in before you can comment on or make changes to this bug.